BSR SCREEN RECORDER

Version 5.1

USER MANUAL

© Copyright 2000-2011 BSRSoft
## TABLE OF CONTENTS

1. INTRODUCTION ................................................................................................ 1
2. MAIN INTERFACE ............................................................................................. 2
   2.1. Video Source Selection ................................................................... 2
   2.2. WatchIt Mode ............................................................................... 3
   2.3. Open Wizard ................................................................................. 3
   2.4. Play Button ................................................................................... 4
   2.5. Stop Button .................................................................................... 4
   2.6. Record Button .............................................................................. 4
   2.7. Pause Button .................................................................................. 4
   2.8. Manual Recording Button ........................................................... 4
   2.9. Take Picture Button .................................................................... 5
   2.10. Convertor Button ....................................................................... 5
   2.11. Movie Studio Button ................................................................. 5
   2.12. Movie Lab Button ..................................................................... 5
   2.13. Shortcut Configuration Keys On The Main Interface of BSR ............ 6
       2.13.1. Save Button ...................................................................... 6
       2.13.2. Menu Button .................................................................... 7
       2.13.3. Mouse Cursor Shortcut Button ........................................ 8
       2.13.4. Audio Settings Shortcut Button ........................................ 10
       2.13.5. Markers Shortcut Button .................................................. 13
       2.13.6. Video Codec Setting Shortcut Button ............................... 13
3. CONFIGURATION OF BSR ............................................................................. 14
   3.1. Screen Tab ....................................................................................... 15
       3.1.1. A Region Of The Screen ...................................................... 15
       3.1.2. A Window .......................................................................... 16
       3.1.3. Entire Screen ...................................................................... 16
       3.1.4. Multiple Region (Picture In Picture) ................................... 16
       3.1.5. Auto-Pan .......................................................................... 17
       3.1.6. Enable Zooming During Recording ..................................... 17
       3.1.7. Display Monitor .................................................................. 17
       3.1.8. Show Region ..................................................................... 17
   3.2. Video Tab ......................................................................................... 18
       3.2.1. Recording Options ............................................................. 18
           i. Record Mouse Pointer ......................................................... 18
           ii. Record Date & Time ......................................................... 20
           iii. Include Watermark ......................................................... 20
           iv. Record Subtitles ............................................................ 21
           v. Disable Acceleration While Recording ............................... 22
           vi. Record Transparent and Layered Windows ...................... 23
       3.2.2. Video Compression/Codec ................................................... 23
       3.2.3. Output Video Dimension ................................................... 23
       3.2.4. Recording And Playback Speed ......................................... 24
1. INTRODUCTION

BSR Screen Recorder (BSR) is a screen recording application which records video, audio and images from the computer desktop. BSR can record whatever visible on the screen, saves videos in AVI (including Xvid and DivX), Flash (SWF), Windows Media (WMV) and Executable (EXE) formats; images to JPG, PNG and BMP formats. Any part of the screen or a window or the entire desktop can be recorded. BSR can be used for recording anything seen on the screen such as web cam sessions, games, any software on the desktop, any video display on the screen. BSR is used for business solutions, to prepare video presentations, tutorials etc. BSR Screen Recorder includes Movie and Photo Studios. Features 2D and 3D zooming during recording.

System Requirements:

Operating System: Microsoft Windows 7 / Vista / Windows XP / 2008 / 2003 / Me / NT / 2000 (compatible with both 32 and 64 bit OS)
CPU: Pentium processor minimum
Memory: 512 MB minimum
Free Hard Drive Space: 20 MB for installing

Download Links:

BSR Screen Recorder for Windows 7, Windows Vista, 2008, 2003 and XP64Bit:
http://www.bsrsoft.com/download.asp?id=21

BSR Screen Recorder for Windows XP, Me, NT, 2000:
http://www.bsrsoft.com/download.asp?id=1

STRUCTURE OF INTERFACE

Sections of BSR Screen Recorder:

- Main Interface
- Options (Configuration Interface)
- Configuration Wizard
- Convertor
- Movie Studio
- Photo Studio
- Movie Lab
2. MAIN INTERFACE

2.1. Video Source Selection:

Click this button to select what you want to record on screen (video source). Options are Full Screen, A Window, A Region, Picture In Picture, Auto-Pan and Preset Regions.

2.1.1. Preset Regions: Preset regions can be defined by the users.
Click **Configure Preset Regions** option to open the settings:

![Configure Preset Regions](image)

Click **New Preset** button to create a new region. Enter the screen coordinates of the regions you want to save or click **Select Region** button to select it on the screen. Finally click **Save** button to save the preset region.

### 2.2. WatchIt Mode:

![WatchIt Mode](image)

Click this option to activate the WatchIt mode. During recording, when the WatchIt mode is activated, BSR Screen Recorder watches the selected source for any change and records only when the content of the source changes. For example when a window is selected for recording, BSR Screen Recorder records
the window when a change/movement in the window/scene occurs. Otherwise it pauses itself and waits for any change in the window’s contents.

This feature can be used in order to record a video stream from the internet. The program only records when there is action in the video stream and pauses/unpauses itself automatically according to the incoming stream.

2.3. Open Wizard :

Opens the configuration wizard.

2.4. Play Button :

Opens the last recorded video with the default media player.

2.5. Stop Button :

Stops recording. Also closes the red frame (region markers) when opened just after region selection.

2.6. Record Button :

Starts recording.

2.7. Pause Button :

Pauses and unpauses recording.
2.8. Take Picture Button:

Takes picture of the selected region of the screen and by default, saves them into 'Photos' directory as JPG files. Photo format can be changed to JPG, PNG or BMP. These files are kept in the Photos directory until you delete them. You can handle these photos in Photo Studio. The drawing mode (smooth or sharp) used during the picture capture can be changed in Other Settings in Options->Options tab->Other Settings. The location of Photos folder can be changed from the File tab in configuration.

The number of the photos you have taken before is shown in the Info panel of the main interface. You can reset the photo number by clicking on the Reset Button. The Reset Button does not delete the existing pictures but it resets the reference number and therefore begins to save over to the existing pictures if there are any.

2.9. Open Wizard:

Opens configuration wizard.

2.10. Convertor Button:

Opens convertor for converting AVI files to SWF, WMV or EXE. *(See the Convertor section for further information)*

2.11. Movie Studio Button:

Opens the Movie Studio in which you can do the following tasks:

- Add Audio, Mix Audio
- Extract Parts From Video, Extract Sound From Video, Extract Picture From Video
- Join Two Videos
- Create Video From Picture Files
- Synchronize Audio And Movie
- Resample AVI file

*(See the Movie Studio section for further information)*

2.12. Movie Lab Button:

Opens the Movie Lab in which you can do the following tasks:

- Add texts
- Add pictures, videos (video in video)
- Add callouts, arrows
- Add mirror object (zoom object)
- Add effects (Color filters, brightness, contrast, blur, sharpen, noise, brush, emboss, mosaic)
- Add highlights
- Add transitions
✓ Add JumpTo objects to skip any frames you want
✓ Add Speed objects (to slow down or speed up any part of the video)

*(See the Movie Lab section for further information)*

BSR Screen Recorder main interface is designed for easy use. Shortcuts for the mostly required BSR settings exist on the main interface.

### 2.13. Shortcut Configuration Keys on the Main Interface of BSR:

On the main interface of BSR, there exists the following shortcut configuration buttons which can be opened by dragging down or double-clicking the colored part at the bottom part of the interface:

![BSR Screen Recorder Interface](image)

It can also be opened from Options->Options tab->Show Shortcut Buttons on BSR Interface.

- **Markers Shortcut Button**
- **Video Codec Settings Shortcut Button**
- **Save Button**
- **Menu Button**
- **Mouse Cursor Button**
- **Audio Settings Shortcut Button**

### 2.13.1. Save Button:

This button is only used when the automatic file saving is disabled. Normally when the auto file saving is active, BSR saves the video files automatically when the recording is completed.
2.13.2. Menu Button:

Menu button opens a setting menu:

**Minimize**: Minimizes the interface.

**Run At Corner**: Runs BSR at the right-bottom corner of the screen.

**Run In Tray**: Runs BSR in the system tray (where the computer time is displayed on the screen) and the main interface will disappear.

**Keep On Top**: Keeps BSR on top of the screen over other applications.

**Signal Sounds**: When checked, BSR plays sounds when starting and stopping recordings, and during countdown while starting recording.

**Last Performance Report**: Will display the last recording’s performance report. Report displays the recording performance graphically:

![BSR Screen Recorder](image)

It the capture performance is low, you can change the priority of BSR among other applications in the system from here also.

**Edit Recording**: Lists options for editing the video in the Movie Studio and Movie Lab of BSR. (Options: Edit Movie in Movie Lab, Synchronize Audio, Change Compression, Change Video Speed, Change Audio Speed, Add Audio, Extract Sound, Extract Video, Extract Pictures, Combine Video With Another)

**Run Adviser**: 
Opens the file size adviser. File size adviser analysis the current settings and recommends user some changes in the setting to reduce the video file size.

**Help** : Opens the help file of BSR.

**Purchase** : Opens purchase window to purchase BSR Screen Recorder and Movie Lab, or to enter your license key.

**Check For New Version** : Click this menu item to find out if a new version is released. We continuously add new features and/or fix existing bugs if there are any. It is recommended to check frequently if a new version of BSR is released.

**Contact** : Click to contact BSRSoft.

**About** : Opens the about window.

### 2.13.3. Mouse Cursor Shortcut Button :

Clicking this button opens the following menu :

**Record Mouse Cursor** : By checking this option, BSR will record mouse cursor movements into the video and photo capture.

**Record Mouse Click Displays** : Checking this option will provide BSR to record mouse clicks to the video. Left mouse clicks are animated as red and right mouse clicks are animated as green circle animation or fixed lines depending on the settings described below on the video.
Record Mouse Click Sounds: Checking this option will provide BSR to record mouse click sounds to the video.

Record Cursor Highlight: Checking this option will provide BSR to highlight the mouse cursor with the specified color, shape, size and transparency.

Click Mouse Cursor & Highlight Settings menu item to open the mouse cursor and highlight settings window below:

This window includes settings for mouse cursor and cursor highlight.

Enabling Record Mouse Click Displays will provide BSR to record mouse clicks to the video.

- Animation Display: Left mouse clicks are displayed as red animation circles and right mouse clicks are displayed as green circles on the video.
- Constant Display: Left mouse clicks are displayed as red lines and right mouse clicks are displayed as green lines on the video. The lines are displayed until the mouse button is released.
- Both: Mouse clicks are displayed with both animations and constant lines on the video.

Enabling Record Mouse Click Sounds will provide BSR to record mouse click sounds to the video.

Enabling Windows Cursor will provide BSR to record the mouse cursor with the current shape.
Enabling **Custom Cursor** will provide BSR to record a custom mouse cursor by selecting the cursor file. BSR includes four custom cursors.

Enabling **Activate Cursor Highlight** will provide BSR to highlight the mouse cursor with the specified color, shape, size and transparency. **Restore Defaults** button restores the default values for the cursor highlight.

### 2.13.4. Audio Settings Shortcut Button:

Clicking this button opens the following menu:

**Record Audio** : When this option is checked, BSR will record audio from the selected audio source into the video.

**Audio Source** : Audio recording source can be selected from this menu.

If audio source (input) lines cannot be detected, then **Audio Source Settings on Windows VISTA / Windows 7** option will display in the menu:

**Audio Source Settings on Windows VISTA / Windows 7** : On Windows Vista and Windows 7, by clicking this menu item BSR will open the Windows sound setting window. Starting with Windows Vista, Windows Vista and Windows 7 operating systems doesn’t allow programs to change the audio recording sources of the sound cards programmatically. Users must change it manually from the Windows’ settings. Therefore BSR opens the Windows Sound setting window and describes to the user how to change it.

**On Other Windows Editions Including Windows XP** :

In the Windows editions except Windows Vista and Windows 7, here in the menu you will see the input audio channel lists which the sound card installed on that computer supports. BSR Screen Recorder uses the capabilities of the sound card installed on that computer. You can select any of the audio sources listed. Examples to the input channels are microphone, line in, CD audio, What U Hear etc. If the Speakers option is not listed or grayed out, it means that the sound card doesn’t have such an input line.

If your sound card doesn’t support recording audio from speakers then you have 2 alternatives:
Solution 1:

You can try connecting a cable (3.5mm audio cable with a male plug at each end) from the “line-out” (or audio out or headphone) port of the computer to the “line-in”, and choose the “line-in” as the recording source in BSR. Or if a "line-in" port doesn’t exit, you can also connect the cable from the "line-out" (or audio out or headphone) port to the "microphone" port and choose "microphone" as the recording source.

When you connect the cable to the headphone port, you may not be able to hear the computer sound. To solve this, you can connect a 3.5mm splitter to the headphones port to be able to connect both the cable and a headphone.

3.5 mm Splitter

Solution 2:

You should either install another sound card which supports that feature on your computer or use BSR on another computer which has a capable sound card.

Record Mouse Click Sounds : When the user clicks mouse while recording, BSR records click sound.

Record Keystroke Sounds : When the user starts typing keyboard during recording, BSR records keystroke sounds in to the video.
**Playback Volumes Setup** : For setting the playback volumes, click this menu item.

**Recording Volumes Setup** : For setting the recording volumes of all input audio lines click this menu option. The following window will open:

![Recording Volume Levels](image)

In this window, you can set the recording volumes of each recording channel of the sound card.

**Warning Levels** :

- **Warn when volume level is lower than** : When this option is checked, BSR will warn user if the recording volume of the selected audio source is lower than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

- **Warn when volume level is higher than** : When this option is checked, BSR will warn user if the recording volume of the selected audio source is higher than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

**Audio Quality** : Audio quality settings can be done here. You can select the frequency (kHz), bits (8 or 16) and whether audio will be stereo or mono.

**Save Quality Settings** : Saves current audio quality settings for the future sessions.

**Other Settings** : Opens Other Settings.
2.13.5. Markers Shortcut Button:

Displays and hides the region markers (red frame). If it is activated or Ctrl+M is pressed, the region markers (red frame) will be displayed on the screen. When this option is not checked and when a region is selected on the screen, the markers will automatically display to indicate the selected region and will be closed when the recording finishes.

2.13.6. Video Codec Setting Shortcut Button:

If the Automatic option is checked in the Video Compression settings of BSR (Options->Video tab->Video Compression), BSR automatically selects a codec installed on the computer. Another video codec which is installed on the computer can be selected by clicking this button. Codecs are third party applications which can be downloaded and installed on the computer independent from BSR Screen Recorder. In BSR, these installed video codecs can be selected and configured by clicking this button. For instance Xvid and DivX codecs can be selected here if they are installed on the computer. For instance selecting the Xvid codec for recording will provide better quality and less file sizes. These codecs can be downloaded from their websites.

When an AVI file is carried to another computer, the video codec used for recording the video must also exist in that computer in order to display/open the video. Microsoft Video 1 is the most common existing video codec. For distributing a recorded video file, if you used a special codec or a codec which may not exist in the target computer, converting AVI file to SWF, WMV or EXE formats in the video convertor before the distribution and then distribute the video in SWF, WMV or EXE format will overcome this problem.
3. CONFIGURATION OF BSR

Clicking the Options button on the main interface of BSR will open the main configuration window.

The main configuration windows of BSR includes:

- Screen tab: Video and image source settings
- Video tab: Settings related to video
- Audio tab: Settings related to audio
- File tab: Video and picture file settings
- Hotkeys tab: Settings for hotkeys
- Options tab: Various option settings
- About tab
3.1. SCREEN TAB :

In this tab, the video source is selected and configured.

3.1.1. A Region of the Screen :

By clicking to the ‘Select Region’ button, any region of the screen can be selected for recording. The region can also be selected by manually entering the pixel coordinates to X,Y, Width and Height text boxes.

BSR will record anything seen in the selected region during recording. A red marker will display on the screen to indicate the selected region and it will flash while recording.

Preset Regions : Preset regions can be defined by the users. Click Configure button to open the preset settings :
Click **New Preset** button to create a new region. Enter the screen coordinates of the regions you want to save or click **Select Region** button to select it on the screen. Finally click **Save** button to save the preset region.

### 3.1.2. A Window:

By clicking to the ‘Select Window’ button, any window open on the desktop can be selected for recording.

**BSR** will record the selected window and its contents. The window can be dragged and moved while recording.

### 3.1.3. Entire Screen:

With this option **BSR** will record the entire screen.

### 3.1.4. Multiple Region (Picture In Picture):

Two regions selected on the screen will be recorded into one video. By clicking to the ‘Select Region’ button, two regions of the screen can be selected for recording. The regions can also be selected by manually entering the pixel coordinates to X, Y, Width and Height text boxes.

The second region can be located to any part of the video by dragging at the screen diagram on the right. The second region is demonstrated with the light gray color on the diagram.

**BSR** will record anything seen in the selected regions during recording.
3.1.5. **Auto-Pan**:

With this option selected a red transparent frame appears on the screen which will follow the mouse cursor. BSR will record where ever the mouse cursor goes. F4 key sets the size of the video. Esc key stops recording. F9 and F10 keys zooms in and out while recording by default.

3.1.6. **Enable Zooming During Recording (F9-F10)**:

When this option is enabled, BSR can zoom in and out during recording by pressing F9 and F10 keys by default. Zoom in and out can be used in ‘A Region of the Screen’ recording, ‘Multiple Regions’, ‘Entire Screen’ and ‘Auto-Pan’ recordings.

3.1.7. **Display Monitor**:

This option opens a monitor to display the selected region on the screen. The video display can be previewed from the monitor.

3.1.8. **Show Region Markers (Ctrl+M)**:

If this option is checked or Ctrl+M is pressed, the region markers (red frame) will be displayed. When this option is not checked and when a region is selected on the screen, the markers will automatically display to indicate the selected region and will be closed when the recording finishes.
3.2. VIDEO TAB:

In this tab, the recording options, video codec, video dimensions and video speeds are configured.

3.2.1. Recording Options:

i. Record Mouse Pointer:

By enabling this option, BSR will record mouse cursor movements into the video and photo capture. Click Mouse Cursor Settings button for further mouse cursor and highlight settings:
This window includes settings for mouse cursor and cursor highlight.

Enabling **Record Mouse Click Displays** will provide BSR to record mouse clicks to the video.

- **Animation Display**: Left mouse clicks are displayed as red animation circles and right mouse clicks are displayed as green circles on the video.
- **Constant Display**: Left mouse clicks are displayed as red lines and right mouse clicks are displayed as green lines on the video. The lines are displayed until the mouse button is released.
- **Both**: Mouse clicks are displayed with both animations and constant lines on the video.

Enabling **Record Mouse Click Sounds** will provide BSR to record mouse click sounds to the video.

Enabling **Windows Cursor** will provide BSR to record the mouse cursor with the current shape.

Enabling **Custom Cursor** will provide BSR to record a custom mouse cursor by selecting the cursor file. BSR includes four custom cursors.
Enabling **Activate Cursor Highlight** will provide BSR to highlight the mouse cursor with the specified color, shape, size and transparency. **Restore Defaults** button restores the default values for the cursor highlight.

**ii. Record Date & Time:**

By enabling this option, BSR will record date and time into the video. Click **Date & Time Settings** button for further settings:

![Record Date/Time](image)

This window includes date and time settings.

Format of the date and time can be set from the **Format** settings. Properties of the date and time display can be configured from the **Properties**. Position of the date and time display on the video can be set from the **Position**. The display of the date and time can be previewed in the **Preview**.

Enabling **Record Mouse Click Displays** will provide BSR to record mouse clicks to the video. Left mouse clicks are animated as red lines and right mouse clicks are animated as green lines on the video.

**Restore Defaults** button restores the default values for the date & time settings.

**iii. Include Watermark:**

By enabling this option, BSR will record a user-specified watermark on to the video. Click **Watermark Settings** button for further watermark settings:
Click **Open Pic File** button to select an image file to be added on the video as watermark. **Transparency slider** sets the transparency of the watermark. **Original Size** button sets the watermark to its original size. **Original Ratio** button sets the original aspect ratio of the watermark. **Undo** button undoes the last change. Watermark can be carried to any place on the video and resized.

**iv. Record Subtitles:**

When this option is enabled, BSR will open a small textbox during recording. Any text written in this text box will be displayed on the video as subtitles.

While screen recording:
Recorded video:

Click **Subtitle Text Settings** button for further subtitle settings:

You can select font, font size, text color and the background of the subtitles.

**v. Disable Acceleration While Recording:**

When this option is available (since the operating system will not allow, it is disabled in Windows Vista and Windows 7), it can be checked to prevent blank video recording. BSR turns off the hardware acceleration automatically just before starting the recording and turns on again when the recording is completed. Checking this option also increases the capture performance.
vi. Record Transparent and Layered Windows:

When this option is checked, BSR will record transparent/layered windows displayed on the screen. Since this option may slow down the recording, it should be used only when needed.

3.2.2. Video Compression/Codec:

If the Automatic option is checked, BSR automatically selects a codec installed on the computer. Another video codec which is installed on the computer can be selected by unchecking the Automatic option and clicking the Change button. Codecs are third party applications which can be downloaded and installed on the computer independent from BSR Screen Recorder. In BSR, these installed video codecs can be selected and configured by clicking this button. For instance Xivd and DivX codecs can be selected here if they are installed on the computer. For instance selecting the Xvid codec for recording will provide better quality and less file sizes. These codecs can be downloaded from their websites. Click Save Codec button to use the selected codec on all sessions. When BSR is launched, it will start up with the last saved codec. Some codecs also supports the Quality setting. The more quality causes more video file size.

When an AVI file is carried to another computer, the video codec used for recording the video must also exist in that computer in order to display/open the video. Microsoft Video 1 is the most common existing video codec. For distributing a recorded video file, if you used a special codec or a codec which may not exist in the target computer, converting AVI file to SWF, WMV or EXE formats in the video convertor before the distribution and then distribute the video in SWF, WMV or EXE format will overcome this problem.

3.2.3. Output Video Dimension:

When Automatic option is enabled, BSR sets the output video dimension rate automatically for a better capture speed (fps). When the selected region on the screen for recording is larger, BSR automatically reduces the output video dimension to increase the capture performance. The output video dimension rate can also be changed to a value up to 500% by the user. The output video dimensions can also be entered as pixel width and height instead of a percentage. The small check box near the Height textbox provides BSR to maintain the aspect ratio of the source. Clicking the small square button just under the Auto option will open the Output Video Size Dialog. When the Auto option is disabled, a small circle appears which provides BSR to save the settings for all sessions when turned on.
3.2.4. Recording And Playback Speeds:

Capture Speed: When the Automatic option is checked, BSR automatically sets the recording speed. But unchecking this option, video capture speed can be configured. The fastest capture speed can be set to 100 frames per 1 second. The slowest is 1 frame per 24 hours. Click on the red button figure to lock the current speed settings for use in all sessions. In WatchIt Mode, speed settings are not used. Computer performance may not allow BSR to capture video at the specified speed due to the computer performance during recording.

Also, the playback speed of the video can be configured in this section. If 'Automatic' option is checked, BSR automatically calculates the optimized playback speed of the recorded video. If not, the playback speed will be the value specified by the user between 1 to 30 frames per second. If the playback speed is 1 fps, then the user becomes able to select 'Play one frame every 2 seconds'. In this case, BSR records every captured frame specified times per specified seconds.
3.3. AUDIO TAB:

In this tab, the audio recording is configured.

When the Record Audio option is checked, BSR will record audio from the selected audio source into the video.

3.3.1. Audio Source:

You can select the audio device if you have more than one audio devices. The default one is automatically selected.

Record Audio From:

Speakers (what you hear): If the sound card installed on the computer contains a channel which will provide audio recording of what is heard from speakers then selecting this option will automatically select the appropriate sound channel required for recording audio heard from speakers. Initially you may need to do the settings once by clicking the Settings For Recording Audio From.
Speakers button. If such a channel is not supported by the sound card, then see the Solutions section below.

Microphone: If the sound card installed on the computer contains a microphone channel, selecting this option will automatically select the appropriate sound channel required for recording audio from microphone.

Other: The audio recording lines which the sound card installed on that computer supports are listed here. BSR Screen Recorder uses the capabilities of the sound card installed on that computer. You can select any of the audio sources listed. Examples to the input channels are 'microphone', 'line in', 'CD audio', 'What U Hear' etc. If the Speakers (i.e. Stereo Mix, Mono Mix, What U Hear) option is not listed, it means that the sound card doesn't have such an input line. In such a case, see the Solutions section below.

BSR is also capable of changing audio recording line in Windows Vista and Windows 7. If somehow BSR is not able to change audio input line selection, only the selected audio source will be displayed. In that case, for changing the audio source, BSR will open the Windows sound setting window. Starting with Windows Vista, Windows Vista and Windows 7 operating systems doesn't allow programs to change the audio recording sources of the sound cards programmatically. Users must change it manually from the Windows' settings. Therefore BSR opens the Windows Sound setting window and describes to the user how to change it.

If the sound card doesn't support recording audio from speakers then there are 2 alternative solutions:

Solution 1:

You can try connecting a cable (3.5mm audio cable with a male plug at each end) from the "line-out" (or audio out or headphone) port of the computer to the "line-in", and choose the "line-in" as the recording source in BSR. Or if a "line-in" port doesn't exit, you can also connect the cable from the "line-out" (or audio out or headphone) port to the "microphone" port and choose "microphone" as the recording source.
When you connect the cable to the headphone port, you may not be able to hear the computer sound. To solve this, you can connect a **3.5mm splitter** to the headphones port to be able to connect both the cable and a headphone.

![3.5 mm Splitter](image)

**Solution 2:**

You should either install another sound card which supports that feature on your computer or use BSR on another computer which has a capable sound card.

When **Don’t allow other applications change audio source during recording** option is checked (not available in Vista & 7), BSR will not allow other applications change audio source during recording. For example when you set recording from Speakers, if the instant messenger tries to change it to microphone BSR will not allow this until the recording ends.

**3.3.2. Recording Options :**

**Record Mouse Click Sounds :** When the user clicks mouse while recording, BSR records click sound.

**Record Keystroke Sounds :** When the user starts typing keyboard during recording, BSR records keystroke sounds in to the video.

**3.3.3. Audio Quality :**
Audio quality settings can be done here. You can select the frequency (kHz), bits (8 or 16) and whether audio will be stereo or mono.

You can also change the audio interleave frequency.

### 3.3.4. Volume Settings:

Recording volume of the currently selected audio input channel can be set here. For setting all lines you should click the **Recording Volumes** button.

![Volume Settings](image.png)

**Warning Levels:**

- **Warn when volume level is lower than** : When this option is checked, BSR will warn user if the recording volume of the selected audio source is lower than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

- **Warn when volume level is higher than** : When this option is checked, BSR will warn user if the recording volume of the selected audio source is higher than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

**Playback Volumes** : For setting the playback volumes, you can click the **Playback Volumes** button.

**Amplify Recording Volume** : BSR automatically amplifies the sound volume in selected rate.

**Show Volume Control During Recording** : BSR opens a volume control on the desktop and the user can set the recording volume during recording with it.
Show Sound Level Meter During Recording: BSR opens a volume level meter which shows the input audio volume during recording.
3.4. FILE TAB:

When the **Save Files Automatically** option is checked, BSR automatically saves the recorded video files into the specified directory. The file is named automatically with the file format specified by the user. The default file name form consists of the date and time of the completion of the recording.

**Change File Name Format:**
Items listed in the Available Fields section can be added to the file name format. File name format can be fully customized by the user. When Overwrite existing files option is selected, BSR overwrites the existing files without warning. Otherwise, BSR will rename the file to a non-existing file name. Autonumber digit number and Autonumber start from fields specify the settings of the Autonumber element and will be used only when the Autonumber item is used in the file name format. File Name Preview displays a sample for the file name format. Defaults button restore the default values.

Enable Multiple File Recording:

When the Enable Multiple File Recording option is checked, BSR automatically switches to a new file when the AVI file exceeds the specified file size.

Temporary Folder:

BSR Screen Recorder uses this temporary folder while recording. You can change the temporary folder from here. Clear BSR Temp Directory button deletes the existing files in the BSR temp directory.

Photos Folder:

BSR Screen Recorder saves captures photo files into this folder.
3.5. HOTKEYS TAB:

In this tab, all BSR hotkeys are configured:

- **Start Recording**: This hotkey starts recording.
- **Stop Recording**: This hotkey stops recording.
- **Pause Recording**: Pauses and unpauses recording.
- **Zoom In**: Zooms in while recording.
- **Zoom Out**: Zooms out while recording.
- **Toggle 3D Zoom**: Opens 3D zoom while recording.
- **3DZoom Tilt Increase**: When 3D zoom is opened, this hotkey increases zoom tilt.
- **3DZoom Tilt Decrease**: When 3D zoom is opened, this hotkey decreases zoom tilt.
- **Pan Region**: When recording ‘a region’ on the screen, pressing this hotkey will move the region (red frame) to the mouse cursor location on the screen.

- **Volume Control/Meter**: This opens and closes the volume control and volume level meter during recording.

- **Take picture**: This hotkey takes picture.

- **Show/Hide Markers**: This hotkey opens/closes the red frame which shows the selected region on the screen.

- **Draw To Screen**: This opens screen drawing mode during recording.

- **3D Mouse Control**: While recording if you press this hotkey, 3D zoom will tilt and zoom in & out according to your mouse cursor movement. While this button is pressed, dragging mouse to left or right will change the 3D zoom tilt; dragging mouse to up or down will change the zoom in and out.

- **3D Zoom In**: When 3D zoom is opened, camera zooms in.

- **3D Zoom Out**: When 3D zoom is opened, camera zooms out.

- **Before Starting To Record, Pause and Wait**:  
  - **This key to start recording**: When the user clicks the Record button, BSR will complete initialization and not start recording and wait this key to start. When this is pressed by the user, BSR immediately starts recording without displaying any further message.
  - **Countdown from number 10 and then start recording**: When the user clicks the Record button, BSR will complete initialization, start to countdown from this number of seconds and starts recording automatically. For example, this option may be useful for games. User can set BSR to start recording in 10 seconds, launch the game and won’t need to click something on BSR interface or press any key; BSR will start recording automatically.
3.6. OPTIONS TAB:

**Start Recording on**: When set, BSR will automatically start recording at the specified date and time.

**Stop Recording on**: When set, BSR will automatically stop recording at the specified date and time.

**BSR Signal Sounds**: When checked, BSR plays sounds when starting and stopping recordings, and during countdown while starting recording.

**Disable Screen Saver While Recording**: When set, BSR disable the system screen saver. BSR Screen Recorder records whatever visible on the screen during recording. If the screen saver runs while recording, it will record the screen saver.

**Run At Corner**: When this option is checked, BSR will run at the right-bottom corner of the screen.
Run In System Tray: When set, BSR will run in the system tray (where the computer time is displayed on the screen) and the main interface will disappear.

Keep On Top: This option keeps BSR on top of the screen over other applications.

Stop Recording At 100th Frame: When set, BSR will automatically stop recording at this frame.

Hide Screen Recorder While Recording: When this option is checked, BSR will completely hide during recording. You should be aware of that there may be no sign about its activity during recording and may finish the hard disk empty space.

Priority For BSR Screen Recorder: This options sets BSR Screen Recorder’s priority among the other running programs during recording. Setting this option to High will provide BSR high priority among other running applications and BSR will gain more CPU resource which will increase the capture performance. Meanwhile, it may cause other applications run slower during recording.

Display All Information Messages & Dialogs: This option will reset all the messages BSR pops up. If the user set BSR not to display any message before, it will start to display again.

Disable Help Balloons: This option prevents BSR to display help balloons.

Show Shortcut Buttons on BSR Interface: When checked, the shortcut buttons on the BSR main interface will be displayed.

3D Zoom Settings:
Activate Dynamic 3D Zoom: When this option is checked, during 3D zoom, the camera angle changes according to the mouse pointer location on the screen.

Angle: Sets the maximum camera angle.

Zoom Rate: Sets the camera zoom rate.

When the user toggles to 3D zoom during recording, the 3D zoom preview window, which shows the 3D tilt and zoom status, opens on the desktop.

Show Preview Always During Recording: 3D preview window will be displayed regardless 3D zoom is active. It will display always during recording.

Show Always Only When Full Screen Is Selected: 3D preview window will be displayed only when entire screen recording is selected and will be displayed during recording.

Show When 3D Zoom Is Active During Recording: 3D preview window will be displayed while 3D zoom is active.

Show Only While Tilting During 3D Zoom: 3D preview window will be displayed only while tilting with the hotkeys to show the user the tilt status.

Never Show 3D Preview: 3D preview window will not be displayed during 3D zoom.

Tilt Limit For 3D Zoom: This option specifies the length of 3D Zoom activation in seconds. Then the user toggles to 3D zoom by clicking the relevant hotkey, BSR will activate the 3D zoom during this specified time and then deactivate 3D zoom automatically.

Background Color: This option specifies the background color to be used for 3D zoom recording. There are 5 predefined colors which can be changed by the user.

Run Adviser:

This button opens the file size adviser. File size adviser analysis the current settings and recommends user some changes in the setting to reduce the video file size.

View Last Performance Report: Will display the last recording’s performance report. Report displays the recording performance graphically:
If the capture performance is low, you can change the priority of BSR among other applications in the system from here also.

**Other Settings:** Will open other settings which are not required very often:
**Capture Settings:**

**Take Picture Hotkey Sensitivity:** Set the sensitivity for the Take Picture hotkey. Increasing the sensitivity may cause multiple shots in one hotkey.

**Default Video Size For ‘Full Desktop’ Recording:** This is not available when Output Video Dimension setting in the Video tab is set to Auto. Otherwise, this option provides BSR to set the output video dimension to 70% of the entire desktop size when full screen recording is selected.

**Capture Speed Level:** This option may be used for reducing the capture speed slightly on computers with very high speed processors.

**Modify video dimensions to multiple of 4:** Changes output video dimension to multiples of 4 which provides more compatibility to most of the video codecs.

**Zoom:**

**Disable Zooming:** If this option is checked, zooming will not be available during recording.

**Play Beep Sound:** If checked, zooming in and out will play a beep sound during recording.

**Slow Camera Motion:** Zoomed are follows the mouse cursor softly.

**Draw Modes:**

Sets the image drawing mode of BSR for video and picture recording separately. Smooth (Halftone) option provides smooth transition of color and Sharp (ColorOnColor) option provides sharp colors.

**Start BSR With:**

**WatchIt Mode On:** Starts BSR Screen Recorder with WatchIt mode activated.

**Signal Sounds Turned Off:** Starts BSR Screen Recorder with signal sounds of BSR turned off.

**Always Select ‘Full Desktop’ As Source:** Starts BSR Screen Recorder with full desktop selected as video source.

**Interface Settings:**

**Do not minimize BSR while recording:** Normally BSR Screen Recorder minimizes itself during recording. Checking this option will not minimize BSR Screen Recorder when the recording starts.

**Do not minimize BSR while playing:** Normally BSR Screen Recorder minimizes itself just before playing a video. Checking this option will not minimize BSR Screen Recorder before the recording starts.
Do not close red frame while playing: Normally BSR Screen Recorder closes the red frame (markers) before starting to play a video. Checking this option will not close the red frame on the screen when opening the video on the default media player.

Shadow:

Drop Shadow Of Main Panel: Drops shadow under the main interface of BSR. Shadow color and its width can be specified by the user. (Not available on Windows Vista and Windows 7)

Fix Region Selection: When this option is checked, BSR uses simple region selection.

Allow region size during recording: When this option is checked, the region boundaries in the Region recordings can be resized during recording.

Fix BSR interface display: If some parts of the BSR user interface is not displayed properly, checking this option should fix the problem.

Audio Settings:

Reverse Mixer Audio Lines: If BSR records from an audio source other than you selected you should check this option. For example, BSR records audio from Speakers in spite of you selected Microphone as the audio source. (Not available in Windows Vista and Windows 7).

Use Audio Delay - Shift: Audio shifts specified amount of seconds.

File Processing:

Leave Video and Audio Files Unmerged: BSR Screen Recorder records video and audio files separately during recording and when the recording is completed it merges them into one file. When this option is checked, BSR will leave the video and audio files unmerged. User can merge them later in Movie Studio-> Add/Mix Audio.

Don’t Move The Files From The Temp Dir: This can only be checked if the ‘Leave Video and Audio Files Unmerged’ option is checked. Option provides BSR to leave the files in the Temporary directory of BSR.

Process Files After Multiple Recording Finishes: BSR Screen Recorder records video and audio files separately during recording and when the recording is completed it merges them into one file. When this option is checked, BSR will not process the files while switching to new files during multiple file recording and process all of them when the recording completely finishes.

Language: Language of BSR user interface can be changed here. Please note that some parts of the application, accompanying files, entire or some part of the product’s website and support will remain English.
3.7. ABOUT TAB:

Check For New Version: Click this button to find out if a new version is released. We continuously add new features and/or fix existing bugs if there are any. It is recommended to check frequently if a new version of BSR is released.

Help: Opens the help file of BSR.

Troubleshooting: Opens the troubleshooting web page.

Credits: Opens the Credits window.

Purchase Now/Register: Click this button to purchase BSR Screen Recorder and Movie Lab, or to enter your license key.
4. CONFIGURATION WIZARD

BSR has also a configuration wizard which opens at startup automatically by default. This wizard provides users to configure BSR step by step.
4.1. WHAT WOULD YOU LIKE TO DO?:

4.1.1. Record Screen:

Select this option for screen recording.

4.1.2. Edit / Produce Video In Movie Lab:

Opens BSR Movie Lab. With BSR Movie Lab, users can add texts, images, videos, callouts, mirrors (zoomins), effects, transitions, speed objects, skip frames (JumpTo) objects into the recorded videos. In BSR Movie Lab, videos can be resampled with new codecs, in new dimensions, with new speed and in new other video formats (SWF, WMV and EXE).

With BSR Movie Lab, users can prepare tutorials, presentations, video for video sharing websites etc. (See Movie Lab section for further information)
4.1.3. Play Video File:

Select this option to play a previously recorded video.

4.1.4. Movie Studio Tasks:

Join Two Videos: Opens Merge screen of BSR Movie Studio for joining two separate video (AVI) files.

Extract/Cut A Video: Opens Extract screen of BSR Movie Studio in which the user can extract any portion of the video into a new file, extract sound of the video into a wave file and save picture of any frame of the video.

Add/Mix Sound Into A Video: Opens Add/Mix Audio screen of BSR Movie Studio for editing the audio of the video. Users can add new audio or mix audio with the existing one.

Make Video From Pictures: Opens Picture To Video screen of BSR Movie Studio for creating video from the picture files.

Open Audio-Video Synchronizer: Opens Audio Synch screen of BSR Movie Studio for editing video for the audio synchronization.

Resample An AVI File: Opens Resample screen of BSR Movie Studio for resampling an AVI file. In this screen the user can change the codec and speed of the video.

Open Photo Studio: Opens Photo Studio for viewing the captured photos.

4.1.5. Open Convertor:

Opens Convertor screen of BSR for converting AVI files to SWF, WMV or EXE. (See Video Convertor section for further information.)

4.1.6. Troubleshooting Link:

Opens the troubleshooting web page for BSR Screen Recorder.
4.2. WHAT WOULD YOU LIKE TO RECORD?

4.2.1. A Region Of The Screen:
Select this option for recording a selected part of the screen. In the next step, it will ask you to select the region you want to record on the screen.

4.2.2. A Window:
Select this option for recording a selected window on the screen. In the next step, it will ask you to select the window you want to record.

4.2.3. Entire Screen:
Select this option for recording the full screen.
4.2.4. Multiple Region (Picture-In-Picture) :

Select this option for recording two selected parts on the screen into one video. In the next step, it will ask you to select the regions you want to record on the screen.

4.2.5. Auto-Pan :

With this option, BSR records wherever the mouse cursor goes.
4.3. AUDIO AND MOUSE CURSOR OPTIONS:

4.3.1. Audio:

Record Audio: When the Record Audio option is checked, BSR will record audio from the selected audio source into the video.

Rec. Volume: Recording volume of the currently selected audio input channel can be set here.

Audio From:

The audio recording lines which the sound card installed on that computer supports are listed here. BSR Screen Recorder uses the capabilities of the sound card installed on that computer. You can select any of the audio sources listed. Examples to the input channels are 'microphone', 'line in', 'CD audio', 'What U Hear' etc. If the Speakers (i.e. Stereo Mix, Mono Mix, What U Hear) option is not listed, it means that the sound card doesn't have such an input line. In such a case, see the Solution section below.
BSR is also capable of changing audio recording line in Windows Vista and Windows 7. If somehow BSR is not able to change audio input line selection, only the selected audio source will be displayed. In that case, for changing the audio source, BSR will open the Windows sound setting window. Starting with Windows Vista, Windows Vista and Windows 7 operating systems doesn't allow programs to change the audio recording sources of the sound cards programmatically. Users must change it manually from the Windows' settings. Therefore BSR opens the Windows Sound setting window and describes to the user how to change it.

If the sound card doesn't support recording audio from speakers then there are 2 alternative solutions:

**Solution 1:**

You can try connecting a cable (3.5mm audio cable with a male plug at each end) from the "line-out" (or audio out or headphone) port of the computer to the "line-in", and choose the "line-in" as the recording source in BSR. Or if a "line-in" port doesn't exit, you can also connect the cable from the "line-out" (or audio out or headphone) port to the "microphone" port and choose "microphone" as the recording source.

When you connect the cable to the headphone port, you may not be able to hear the computer sound. To solve this, you can connect a **3.5mm splitter** to the headphones port to be able to connect both the cable and a headphone.
**Solution 2:**

You should either install another sound card which supports that feature on your computer or use BSR on another computer which has a capable sound card.

**Record Mouse Click Sounds:** When the user clicks mouse while recording, BSR records click sound.

**Record Keystroke Sounds:** When the user starts typing keyboard during recording, BSR records keystroke sounds into the video.

**Amplify Recording Volume:** BSR automatically amplifies the sound volume in selected rate.

*In the configuration wizard, there exists only a part of the configuration options which are used more frequently. For the other configuration options which don’t exist in the wizard, you should open BSR Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR for further information.)*

**4.3.2. Mouse Cursor:**

Enabling **Record Mouse Click Displays** will provide BSR to record mouse clicks to the video.

- **Animation Display:** Left mouse clicks are displayed as red animation circles and right mouse clicks are displayed as green circles on the video.
- **Constant Display:** Left mouse clicks are displayed as red lines and right mouse clicks are displayed as green lines on the video. The lines are displayed until the mouse button is released.
- **Both:** Mouse clicks are displayed with both animations and constant lines on the video.

**Highlight Mouse Cursor:** This will provide BSR to highlight the mouse cursor with the specified color, shape, size and transparency.

**Cursor & Highlight Settings:** Click this button for further mouse cursor and highlight settings:
Enabling **Record Mouse Click Sounds** will provide BSR to record mouse click sounds to the video.

Enabling **Windows Cursor** will provide BSR to record the mouse cursor with the current shape.

Enabling **Custom Cursor** will provide BSR to record a custom mouse cursor by selecting the cursor file. BSR includes four custom cursors.

Enabling **Activate Cursor Highlight** will provide BSR to highlight the mouse cursor with the specified color, shape, size and transparency. **Restore Defaults** button restores the default values for the cursor highlight.

*In the configuration wizard, there exists only a part of the configuration options which are used more frequently. For the other configuration options which don’t exist in the wizard, you should open BSR Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR for further information.)*

**Start Recording**: Clicking this option immediately starts recording.
4.4. RECORDING OPTIONS :

![BSR Screen Recorder](image)

4.4.1. Options :

i. Include Date/Time :

When this option is checked, BSR will record date and time into the video. Click Date & Time Settings button for further settings :
Format of the date and time can be set from the Format settings. Properties of the date and time display can be configured from the Properties. Position of the date and time display on the video can be set from the Position. The display of the date and time can be previewed in the Preview.

Enabling Record Mouse Click Displays will provide BSR to record mouse clicks to the video. Left mouse clicks are animated as red lines and right mouse clicks are animated as green lines on the video.

Restore Defaults button restores the default values for the date & time settings.

ii. Include Watermark :

By checking this option, BSR will record a user-specified watermark on to the video. Click Watermark Settings button for further watermark settings:
Click **Open Pic File** button to select an image file to be added on the video as watermark. **Transparency slider** sets the transparency of the watermark. **Original Size** button sets the watermark to its original size. **Original Ratio** button sets the original aspect ratio of the watermark. **Undo** button undoes the last change. Selected watermark will be displayed and can be carried to any place and resized.

**iii. Record Subtitle Text:**

When this option is enabled, BSR will open a small textbox during recording. Any text written in this text box will be displayed on the video as subtitles.

While screen recording:

![Subtitle Text Box](image1)

Recorded video:

![Subtitle Text Box](image2)

Click **Text Settings** button for further subtitle settings.
You can select font, font size, text color and the background of the subtitles.

iv. Disable Acceleration (Prevents Blank Recording):

When this option is available (since the operating system will not allow, it is disabled in Windows Vista and Windows 7), it can be checked to prevent blank video recording. BSR turns off the hardware acceleration automatically just before starting the recording and turns on again when the recording is completed. Checking this option also increases the capture performance.

v. Record Transparent/Layered Windows:

When this option is checked, BSR will record transparent/layered windows displayed on the screen. Since this option may slow down the recording, it should be used only when needed.

Show Markers:

If this option is checked, the region markers (red frame) will be displayed. When this option is not checked and when a region is selected on the screen, the markers will automatically display to indicate the selected region and will be closed when the recording finishes.

Show Monitor:

This option opens a monitor to display the selected region on the screen. The video display can be previewed from the monitor.
4.5. VIDEO OPTIONS :

4.5.1. Compression :

If the Automatic option is checked, BSR automatically selects a codec installed on the computer. Another video codec which is installed on the computer can be selected by unchecking the Automatic option. Codecs are third party applications which can be downloaded and installed on the computer independent from BSR Screen Recorder. These installed video codecs can be selected and configured here. For instance Xvid and DivX codecs can be selected here if they are installed on the computer. For instance selecting the Xvid codec for recording will provide better quality and less file sizes. These codecs can be downloaded from their websites.

When an AVI file is carried to another computer, the video codec used for recording the video must also exist in that computer in order to display/open the video. Microsoft Video 1 is the most common existing video codec. For distributing a recorded video file, if you used a special codec or a codec which may not exist in the target computer, converting AVI file to SWF, WMV or EXE formats in
the video convercor before the distribution and then distribute the video in SWF, WMV or EXE format
will overcome this problem.

4.5.2. Recording Options:

Disable Screen Saver During Recording: When set, BSR disable the system screen saver. BSR
Screen Recorder records whatever visible on the screen during recording. If the screen saver runs while
recording, it will record the screen saver.

Priority For BSR Screen Recorder: This options sets BSR Screen Recorder’s priority among the
other running programs during recording. Setting this option to High will provide BSR high priority
among other running applications and BSR will gain more CPU resource which will increase the capture
performance. Meanwhile, it may cause other applications run slower during recording.

Capture Speed: Sets the video capture speed. The fastest capture speed can be set to 100
frames per 1 second. The slowest is 1 frame per 24 hours. Click on the red button figure to lock the
current speed settings for use in all sessions. In WatchIt Mode, speed settings are not used. Computer
performance may not allow BSR to capture video at the specified speed due to the computer
performance during recording.

Dimensions: Sets the rate of the output video dimension. When Automatic option is enabled
in the Video tab of main configuration, BSR sets the output video dimension rate automatically for a
better capture speed (fps). When the selected region on the screen for recording is larger, BSR
automatically reduces the output video dimension to increase the capture performance. The output
video dimension rate can be changed here by the user. The output video dimensions can also be
entered as pixel width and height instead of a percentage. Click the small circle to save the dimension
settings for all sessions.

In the configuration wizard, there exists only a part of the configuration options which are used more
frequently. For the other configuration options which don’t exist in the wizard, you should open BSR
Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR
for further information.)
4.6. AUDIO OPTIONS:

4.6.1. Audio Quality:

Audio quality settings can be done here. You can select the frequency (kHz), bits (8 or 16) and whether audio will be stereo or mono.
4.6.2. Volume Settings:

For setting the volumes of the available recording lines, you should click the Recording Volumes button.

Warning Levels:

Warn when volume level is lower than: When this option is checked, BSR will warn user if the recording volume of the selected audio source is lower than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

Warn when volume level is higher than: When this option is checked, BSR will warn user if the recording volume of the selected audio source is higher than the specified volume here. (BSR will only warn if the volume control is closed during recording. If it is open, the user will already see and change the recording volume during recording.)

For setting the playback volumes, you can click the Playback Volumes button.

Show Volume Control During Recording: BSR opens a volume control on the desktop and the user can set the recording volume during recording with it.

Show Sound Level Meter During Recording: BSR opens a volume level meter which shows the input audio volume during recording.

In the configuration wizard, there exists only a part of the configuration options which are used more frequently. For the other configuration options which don’t exist in the wizard, you should open BSR Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR for further information.)
4.7. HOTKEYS & MISCELLANEOUS SETTINGS:

4.7.1. Hotkey Settings:

Hotkeys can be configured here. (Please see Section 3.5 – Hotkey Tab section for detailed information about hotkey settings.)

4.7.2. Miscellaneous Settings:

Save Files Automatically To: BSR automatically saves the recorded video files into the specified directory. The file is named automatically with the date and time of the completion of the recording.

BSR automatically switches to a new file/or stop recording when the AVI file exceeds the specified file size.

Start Recording on: When set, BSR will automatically start recording at the specified date and time.
**Stop Recording on**: When set, BSR will automatically stop recording at the specified date and time.

**Slow Camera Motion**: Zoomed are follows the mouse cursor softly.

*In the configuration wizard, there exists only a part of the configuration options which are used more frequently. For the other configuration options which don’t exist in the wizard, you should open BSR Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR for further information.)*
4.8. CONFIGURATION COMPLETED:

It shows that the configuration of BSR through the wizard configuration wizard has ended. The user can click the **Start Recording** button to start the recording immediately or **Done** button to close the wizard and activate the main interface.

In the configuration wizard, there exists only a part of the configuration options which are used more frequently. For the other configuration options which don’t exist in the wizard, you should open BSR Configuration by clicking the Options button on the main interface. (See Section 3 – Configuration of BSR for further information.)
5. VIDEO CONVERTOR

Convertor can be used to convert AVI files to SWF (Flash), WMV (Windows Media Video) and EXE (Executable File) format videos.
5.1. RESAMPLE AVI VIDEO:

AVI files can be resampled with a new codec and/or playback speed.

**AVI File - Source File:** Source file to be resampled.

**AVI File – Destination File:** Destination AVI file to be created.

**Original AVI Information:** Video dimensions, length, file size, codec information is displayed.

**Properties of New AVI:**

**Codec:** Codec to be used in the new video can be selected here.

**Speed:** Playback speed of the new video is specified here in frame per seconds. For fast or slow displays, the speed of the video can be changed here.

**Change Both Codec And Speed:** AVI file is created with the user specified codec and playback speed.

**Change Only Speed:** Changes only the playback speed of the video. If the video includes an audio stream, the duration and speed of the audio doesn’t change. This may cause the video and audio unsynchronized.
Include Audio: When this option is checked, if the source AVI file has an audio stream, it will be copied to the new video.
5.2. SWF CONVERTOR:

**AVI File**: File to be converted to SWF.

**SWF File**: Location of SWF file to be created.

**HTML File**: Location of HTML file to be created. This file is created only if 'Create Html File' option is checked.

**Include Audio**: If checked and movie file contains audio, audio will be included in the flash file.

**Add Controls**: If checked, PLAY, STOP and PAUSE buttons will be included in the created flash movie.

**Auto Play**: When SWF file is loaded by flash movie player (for instance internet browser) it automatically starts to play.

**Loop**: When ends while playing, Flash movie returns to the beginning and plays again.

**Background/Border Color**: Defines background (and also border) color when movie is created in Html files.

**Border Size**: Thickness of the border. (Default is 4)

**Play Movie After Finished**: If Html file is created, converted file (SWF file) is started to play in default html player.
**Play Button** : Plays the converted SWF file by opening the generated HTML file. This setting is applicable only if the converter is set to generate the HTML file.

**Restore Defaults** : Restores SWF converter to its default values.

**Advances >> Button** : Opens advanced settings.

**Quality** : 16 bit or 32 bit colors can be selected. Selecting 32 bit colors will increase the quality and the file size. 32 bit setting will also remove unwanted lines from the video if there are any.

**Keyframe Every** : Keyframe rate setting for SWF file. (1-80 : Default is 15)

**Playback Rate** : Frame per second setting of SWF file. (1-80 : Default is 30)

**Use ADPCM Audio Compression** : Compresses audio in ADPCM format.

**Adapt Audio** : If audio format (sample per second) of the AVI file is not appropriate for SWF, it changes audio format before converting to SWF.

**Split To Several Files When Exceed 16000 Frames** : When SWF file exceeds 16000 frames (which is the frame number limit for SWF files), it splits the movie into several parts.

**Connect Ends Of Splited Files To Each Other** : When the movie is split into several parts, it connects movies to each other. When the playing one ends the next one starts automatically.

**Load Another Flash Movie When Finishes** : When checked, SWF player loads a specified other SWF Movie file. If the new loaded file is set to play automatically when loaded, it will start playing automatically.

**Create Html File** : Creates html file to play the converted SWF file in the default internet browser.

**Html Title** : Title for the html file to be created can be specified by user.

**Add Hyper Link To Html** : Adds an hyper link to the end of html file (just after the movie).

**Text** : Text of hyper link.

**Link** : Link of hyper link.
5.3. WMV CONVERTOR:

**AVI File**: File to be converted to WMV.

**WMV File**: Location of WMV file to be created.

**Video Codec**: Lists installed Windows Media Video codecs in the computer.

**Auto**: If checked, the converter automatically selects a video codec for converting to WMV.

**Quality**: Video quality of the movie. The higher quality, the higher file size.

**Keyframe Spacing**: Keyframe spacing in seconds. (1-30 : Default : 5)

**Bitrate**: Effects the quality of the resulted video. The higher bitrate, the higher quality and the higher file size. (By checking the box near the slider, custom bitrate amount can be entered manually).

**Audio Codec**: Lists installed Windows Media Audio codecs in the computer. Only available if selected AVI file includes audio.
**Include Audio**: If AVI file contains audio and this option is checked, audio will be included into the WMV file.

**Auto**: If checked, the converter automatically selects an audio codec for converting to WMV.

**Apply Multipass**: Converter multipasses conversion process. This may provide better quality and lower file size.

**Play After Converted**: Converted file (WMV file) starts to play in default WMV player just after the conversion completed.

**Restore Defaults**: Restores WMV converter to its default values.
5.4. EXE CONVERTOR:

**AVI File**: File to be converted to EXE.

**EXE File**: Location and name of EXE file to be created.

**Include Audio**: If AVI file contains audio and this option is checked, audio will be included into the EXE file.

**Auto Play**: If checked, the EXE video player is set to play the video automatically when launched.

**Auto Loop**: If checked, the EXE video player is set to play the video repeatedly.

**Video Quality**: Specifies a value between minimum quality 1 and maximum quality 100. Default Value is 80.

**Video Created By**: Name of the user who converts AVI to EXE. This information will be displayed in the Info About Video option in the About menu of the BSR Video Player.

**Message To Viewer**: Message from the user who converts AVI to EXE can be entered to be displayed in the Info About Video option in the About menu of the BSR Video Player.

**Restore Defaults**: Restores EXE converter to its default values.
6. MOVIE STUDIO

Clicking the Studio button on the main interface of BSR will open the following window:

![Open Movie Studio](image)
6.1. ADD/MIX AUDIO:

In this window, you can

- record audio (such as narration) or use an existing sound file (wave file) to add or mix or append it into the opened video
- change the volume of the audio of the existing audio
- merge separate video and audio files.

Click Open AVI File button to open a video.

Audio From Sound File: Select this option if you want to add audio into video from a sound file. When this option is selected, Open Sound File button will be activated. Click Open Sound File button to select a wave file for adding into the video.

Record Audio: Select this option if you want to record audio from the selected audio source. Click Select Audio Source button to select the audio source.
Click **Record** button to start audio recording, **Play** button to listen to the recorded audio, **Stop** button to stop recording or playing. Click **Save** button to save the recorded audio into a wave file.

**Mute Audio During Recording** : If checked, it will mute if audio exists in the video.

**Add Mouse Click and Keystroke Sounds Button** : Click this button to open a BSR syn file. If the “Leave Video and Audio Files Unmerged” option that exists in Options->Option tab->Other Settings is checked then BSR leaves recorded video and audio files unmerged. In that case, BSR will also save a file including the mouse click and keystroke information into the folder where the audio file is saved.

**Mix Audio/Add Audio/Append Audio** :

- **Mix Audio** : If the video already includes an audio stream then the selected (or recorded) audio will be mixed with the existing one. This can be used to add narration to the video which already has an audio. Or, this option can be used for adding a background music.

- **Add Audio** : This option will overwrite the existing audio of the video with the selected/recorded new audio.

- **Append Audio** : If the video has an audio stream, this option will append the new audio at the end of the existing one.

**Volume** : When clicked to the Apply button, it will change (increase or decrease) the volume of the audio from the specified rate.

**Mute** : It will mute the audio when viewing the video.

**Play and Stop Buttons** : Press Play button to start playing the video and audio. And Stop button to stop playing.

**Add/Mix Audio Into The Movie** : Click this button to add or mix the audio into the video. It will ask a filename to create a new video with the new audio.

**Play New Movie File** : Click this button to open the new created video in the default media player.
6.2. AUDIO SYNCHRONIZATION:

In this window, you can

- **change speeds** of the video and audio streams,
- **insert silence** to anywhere in the audio stream
- **delete** any part of the audio

to synchronize the audio with video.

Click **Open AVI File** button to open a video.

Opening an AVI movie file will display its video and audio streams in the time scale. There are two methods for audio synchronizing:

1) **Using Stretch Audio buttons**

This is the better and easier method for synchronization. While watching the video you can click on -2x,-1x,+1x,+2x buttons until you decide that the movie is synchronized. For instance, if the video is faster than audio, you should click on -2x and -1x buttons to decrease video speed. Or, if the video is slower than audio, you should click on +1x and +2x buttons to increase video speed.
You can use Loop functions to work on a specific part of the movie. Loop will play the video between loop markers (red markers) repeatedly.

2) Use markers

In order to synchronize, you may also mark the points both on the video and audio scales separately which these points are supposed to be played at the same time when synchronized. Add markers as much as possible for getting better results. Each marker consists of two pointers with same color (one for video and one for audio). By pressing the ‘Synchronize To Markers’ button, BSR Movie Studio will try to synchronize video and audio streams automatically according to your latest marker by changing the video stream's playback speed. In order to get better results, markers should be added towards the end of the video. In case this auto-synchronization does not provide an exact solution, you can edit your movies audio stream by inserting silence in any length you desire or you can delete any part of the audio you selected. And finally you can also change the speeds of video and/or audio streams separately.

Clicking the 'Mark This Video Frame' will mark the current video frame. Click on the video and/or audio scales in order to add or relocate the markers. Enabling 'Force Audio Timing' option will cause BSR Movie Studio to play audio on its real time during preview. If audio skips during playing, you can try to disable this option. It has no effect on the original AVI file.

You should click on the 'Apply' button in order to apply the changes into the AVI file you're working on.
6.3. EXTRACT :

In this window, you can

- cut any part of the video
- change compression (codec) of the video
- save any frame of the video as picture
- save audio of the video into a wave file

Click **Open AVI File** button to open a video.

Here, you can extract parts from the opened video. Mark the beginning and the end points with **left and right markers** (green markers). You can extract either inside or outside part of the markers. Select any compression (codec) installed in your computer for creating the new extracted video file. You can also enter the frame numbers for the left (beginning) and right (ending) markers. Click **Copy Selected Part To A New File** button to extract the select part of the video into a new file.

If audio exists in the movie, audio will be extracted with the video. If you want to extract the video without audio, check 'Do not extract audio' option.

**Save Sound To WAV File** : Click this button to extract the sound of the video into a WAV file.
Save Picture Of The Frame: Click this button to save the currently displayed frame to as picture file.

Open Photos Folder: Click this button to open the photos folder where BSR is saving the picture files.

Play New Created File: Click this button to open the new created video in the default media player.
6.4. MERGE :

In this window, you can

- merge two AVI files
- change compression (codec) of the new video
- specify the speed and size of the new video

Click **Open AVI File 1** button to open the first video.

Click **Open AVI File 2** button to open the second video.

Click **Merge Movies** button to combine two AVI files into one file.

You can select any compressor (codec) installed in your computer for the new video file, specify its new speed and dimensions.

BSR also combines the audio streams of the movies if possible. If you don’t prefer to include the audio of any of the videos, just uncheck the **Include Audio** option for each video.

**Play New Movie** : Click this button to open the new created video in the default media player.
**Speed of the new video:** If the playback speeds of the videos are different, you can first open one of the videos in the Movie Lab and reconstruct the video for speed to obtain the same speed with the other video. (See the Produce Video part of section 7 Movie Lab for reconstructing video for a different speed.)
6.5. PICTURE TO VIDEO :

In this window, you can

- create slide show video from selected picture files
- add text on the created video
- specify the compression (codec) of the video

Select picture files or the folder including the pictures you want to include into the video. You can specify the speed of the video from the slowest 1 picture display for every 60 seconds to the fastest 30 pictures per second:

For 1 picture per 60 seconds, you should set Display One Picture Per .... Seconds to 60 seconds.

For 30 pictures per 1 second, you should set uncheck the Display One Picture Per .... Seconds option and set Speed to 30 fps.

You can select any compressor (codec) installed in your computer to create the video, and specify video dimensions. You can also record any text you specify by checking the Record Text On Video option such as a date or a title etc. You can set the vertical location of the text on the video and the font size.
Uncheck the 'Keep Aspect Ratio' option if you do not want to keep the pictures’ original aspect ratios.

Click on the 'Make Movie' button in order to create the video. While creating new video, all pictures in your list will be displayed on your screen at top. You can terminate this process by pressing the 'ESC' key.
6.6. RESAMPLE :

In this window, you can

- resample a video by changing its compression (codec) and the speed
- change only the speed of the video

Click Open An AVI File button to open a video.

When you open an AVI file, the information about this file will be displayed under AVI information part. You can press on the play button in order to play it with your default AVI player.

You can specify new speed and/or compressor (codec) for the new AVI file. Then click on the 'Resample AVI File' in order to choose a name for the new file and resample it. You can press the 'ESC' key to terminate the resampling process.

Check Change only the speed of the video option if you don’t want to change the codec. This will only change the speed of the video very quickly.

After resampling, you can play new AVI by clicking on the 'Play New Movie File' and display information about the new file by clicking on the 'Display New File's Info' option.
6.7. CONVERT TO SWF:

See section 5.2.

6.8. CONVERT TO WMV:

See section 5.3.

6.9. CONVERT TO EXE:

See section 5.4.

6.10. PHOTO STUDIO:

In this window, you can

- view the captured pictures by BSR Screen Recorder
- save all or any of them to another folder
- delete all or any of them
- play captured pictures as slide show with the specified speed
- pass all captured photos to the “Picture To Video” module of the Movie Studio for creating video from the captured picture files.

6.11. MOVIE LAB:

See section 7.
7. MOVIE LAB

BSR Movie Lab is an AVI editor which mainly designed for editing screen recording videos. However it can also be used for other externally recorded AVI files when it is compatible with its audio format and video codec.

7.1. BRIEFLY MOVIE LAB INTERFACE :

Click New Project (Open AVI File) option in the File menu and select the AVI file you want to open for editing.
Various objects can be added into the opened video. These objects are textboxes, image files, video (AVI) files, arrows, callouts, transitions, effects, mirrors (zoom in), JumpTo object to skip any part of the video, speed object to slow down or speed up any part of the video and highlights.

Objects can be added into the video by clicking to or dragging from the toolbox or from the Edit menu:

**Toolbox:**

![Toolbox Image]

**Edit Menu:**

![Edit Menu Image]

Every object added to the project is shown in the grid window. Each kind of object has a different color in the grid window. Their durations, start & end points can be edited in this window:

**Grid Window:**

![Grid Window Image]

Textboxes, pictures, videos, arrows, callouts and mirrors added into the video have a transparency property that can be set by the user. Whole video or any single frame can be previewed.
Clicking the 'Produce Video' (exists in the File menu) will create a new AVI file by drawing the user-added objects into the video. Video can be created in a custom dimension, speed, and with a custom codec selected among the ones installed in the computer.

Properties Window:

Properties of the AVI file and currently selected object is displayed in properties window which is located on the right of the screen.
**AVI File Information** : Click small button at left bottom to display/hide the AVI File Info.

**Control Panel**

Control Panel is located at the bottom of the screen which is used for navigating through the movie and for editing the currently selected objects start / end frames and their durations by seconds or frames.
Video Display Window

Video frame window is the window which the frames of the video and added objects are displayed. Some object properties such as their location, sizes, display orders can be set in the video display window.

![Sample Project](image)

Toolbar:

Located at the top, including shortcut buttons for many controls of the Movie Lab:
7.2. OBJECTS:

Objects which can be added into the video are textboxes, image files, video (AVI) files, arrows, callouts, transitions, effects, mirrors (zoom in), JumpTo object to skip any part of the video, speed object and highlights.

Objects can be added into the video by clicking to or dragging from the toolbox or from the Edit menu:

**Toolbox:**

**Edit Menu:**

![Toolbox and Edit Menu](image)

7.2.1. Text Object:

Click the button on the toolbar to add a text object into the video.

Text object is used for adding any text into the video. **Display duration** of the added text object is set to 5 seconds by default starting from the current frame. Start and end frames and durations of a text object can be easily changed from the Video Grid Window by sizing and moving object's bar; or by entering values to Object Duration Setting:
Grid Window :

![Grid Window Image]

Object Duration Setting :

<table>
<thead>
<tr>
<th>Frame</th>
<th>Time</th>
<th>Start</th>
<th>Frame</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>4</td>
<td>45</td>
<td>84</td>
<td></td>
</tr>
<tr>
<td>40 frames</td>
<td>4 seconds</td>
<td>15 frames</td>
<td>84 frames</td>
<td></td>
</tr>
</tbody>
</table>

Following properties of text can be specified by user :

Object No : Shows the object number of the selected object
Type : Shows type of the selected object.
Text : Text to be displayed. Text can also be entered by double clicking of the selected text object in the video frame display.
Font Name, Font Size : Font properties of the text
Alignment : Alignment of the text : Left-Center-Right
Text Color, Bold, Italic : Font properties of the text. Click colored button for choosing the text color from the color box. Or enter heximal number of desired color.
Fill : Fills the textbox with the 'Back Color'.
Border : Draws border for the text box. Border is drawn into the produced video; not displayed in design mode, click 'Preview Frame' button in the toolbar to preview the frame.
Back Color : Color to be used to fill the text object box. Click colored button for choosing a color from the color box. Or enter the heximal number of desired color.
Transparency : Specifies transparency level of the object. (0-Solid, 255-Most Transparent). Transparency is drawn into the produced video; not displayed in design mode, click the 'Preview Frame' button in the toolbar to preview the frame, or 'Preview Video' button to preview video. Drawing transparent objects takes more time to complete processing during 'Produce Video' process.
X, Y : Location of the text. X-Y coordinates in pixel.
Width, Height : Size of the text box.
Fade In/Fade Out : Objects fade in or out in the produced video or previews; not displayed in design window.
Right-click on a text object to display the **Object Menu**.

Click **Frame Preview** and **Video Preview** buttons located in the toolbar to preview effects such as transparency which are not displayed in design mode.
7.2.2. Picture/Video Object:

Click button on the toolbar to add a picture or a video object into the video.

Picture object is used for adding a picture or a video into the video. **Display duration** of the added picture object is set to 5 seconds by default starting from the current frame. Start and end frames and durations of a picture object can be easily changed from the Video Grid Window by sizing and moving object's bar; or by entering values to Object Duration Setting:

Grid Window:

```
<table>
<thead>
<tr>
<th>Frame</th>
<th>40</th>
<th>45</th>
<th>50</th>
<th>55</th>
<th>60</th>
<th>65</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Object Duration Setting:

```
<table>
<thead>
<tr>
<th>Frame</th>
<th>40</th>
<th>45</th>
<th>50</th>
<th>55</th>
<th>60</th>
<th>65</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>4</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td>00:00:04</td>
<td>00:00:07</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Following properties of pictures can be specified by user:

- **Object No**: Shows the object number of the selected object
- **Type**: Shows type of the selected object.
- **File**: Name of the picture or video file. When you move the mouse pointer over the file name, its full path is displayed. Click the button next to the file name to choose another file.
- **X,Y**: Location of the picture/video. X-Y coordinates in pixel.
- **Width, Height**: Size of the picture or video.
- **Border**: Draws border for the picture object. Border is drawn into the produced video; not displayed in design mode, click 'Preview Frame' button in the toolbar to preview the frame.
- **Transparency**: Specifies transparency level of the object. (0-Solid, 255-Most Transparent). Transparency is drawn into the produced video; not displayed in design mode, click the 'Preview Frame' button in the toolbar to preview the frame, or 'Preview Video' button to preview video. Drawing transparent objects takes more time to complete processing during 'Produce Video' process.
- **Fade In/Fade Out**: Objects fade in or out in the produced video or previews; not displayed in design window.
- **Set To Original Size**: Click this button to set the picture or video to its original size.
Right-click on a picture object to display the **Object Menu.**

![Object Menu](image)

**Saving any part of the video frame as picture:**

- Select a region on the video frame window by dragging mouse pointer while CTRL key+left mouse button is pressed,
- A green border will appear to indicate your selection,
- Click right mouse button to display the menu and click 'Save Selection as Picture File' to save the selection as a picture file or 'Save Selection as Picture And Paste Into This Frame' to paste the saved picture into the frame.

**Important : File Locations of Pictures/Videos Existing In The Movie Lab Projects**

When picture and video files are added into the video, BSR Movie Lab saves their file location on the hard disk to the project file. When a previously saved project is open in the Movie Lab, it will open the picture files existing in the project from their saved locations. Therefore it is important not to delete or move these files from their locations. Otherwise the Movie Lab will not be able to find those files when opening the project. If the Movie Lab cannot find a picture or a video file existing in the project, it will display a question mark in the video instead of that picture or video. In such a case, you can manually set the location of the picture or video file from the Properties of the picture object.

![Frame Preview and Video Preview buttons](image)

Click **Frame Preview** and **Video Preview** buttons located in the toolbar to preview effects such as transparency which are not displayed in design mode.
7.2.3. Callout, Arrow & Various Object (Image Object):

Click button on the toolbar to add an arrow object, button to add a callout, button to add a ‘various’ object into the video.

Image object is used for adding ready built-in images into the video. Display duration of the added image object is set to 5 seconds by default starting from the current frame. Start and end frames and durations of an image object can be easily changed from the Video Grid Window by sizing and moving object’s bar; or by entering values to Object Duration Setting:

Grid Window:

Object Duration Setting:

Following properties of images can be specified by user:
Object No: Shows the object number of the selected object.
Type: Shows type of the selected object.
No: Number of the image. Click the button next to the number to change the image with another one.
X,Y: Location of the image. X-Y coordinates in pixel.
Width, Height: Size of the image.
Border: Draws border for the image object. Border is drawn into the produced video; not displayed in design mode, click 'Preview Frame' button in the toolbar to preview the frame.
Transparency: Specifies transparency level of the object. (0-Solid, 255-Most Transparent). Transparency is drawn into the produced video; not displayed in design mode, click the 'Preview Frame' button in the toolbar to preview the frame, or 'Preview Video' button to preview video. Drawing transparent objects takes more time to complete processing during 'Produce Video' process.
Fade In/Fade Out: Objects fade in or out in the produced video or previews; not displayed in design window.
Set To Original Size: Click this button to set the image object to its original size.
Change Icon: Click this button to change the object another image.
Change Color: Click this button to change the color of the image.

Click on Pick Color and then an image object existing in the video frame to pick the same color.

Right-click on an image object to display the Object Menu.
Click **Frame Preview** and **Video Preview** buttons located in the toolbar to preview effects such as transparency which are not displayed in design mode.

**How To Add A Callout With Text:**

1) Add a box from Callouts in the Toolbox:

2) Add a text object on to the callout box:

3) Add the tail from the Callouts in the Toolbox:

4) Group all into one by clicking the **Group** option in the right-click menu:
7.2.4. Mirror Object :

Click button on the toolbar to add a mirror object into the video.

Mirror object is used for adding a mirror of a user-specified region of the video.

- Select a region on the video frame window by dragging mouse pointer while CTRL key+left mouse button is pressed
- A green border will appear to indicate your selection
- Click right mouse button to display the menu and click 'Create Mirror of Selection'

Mirror object can also be used for zoom-in and for emphasizing any part of the video.

Display duration of the added mirror object is set to 5 seconds by default starting from the current frame. Start and end frames and durations of a picture object can be easily changed from the Video Grid Window by sizing and moving object's bar; or by entering values to Object Duration Setting:

Grid Window:
Object Duration Setting:

<table>
<thead>
<tr>
<th>Object Duration</th>
<th>Start</th>
<th>End</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame</td>
<td>40 frames</td>
<td>Frame</td>
</tr>
<tr>
<td>Time</td>
<td>4 seconds</td>
<td>Time</td>
</tr>
<tr>
<td>Time</td>
<td>00:00:07</td>
<td></td>
</tr>
</tbody>
</table>

Following properties of mirrors can be specified by user:

- **Object No**: Shows the object number of the selected object.
- **Type**: Shows type of the selected object.
- **Source X,Y**: Location of the mirror source. (X-Y coordinates in pixel.) Source is the part of which will be displayed in the mirror.
- **Source Width, Height**: Size of the source.
- **Change Source**: Click this button to change source location and/or size from the video frame window.
- **Destination X,Y**: Location of the mirror. X-Y coordinates in pixel. Created mirror is displayed at this location.
- **Destination Width, Height**: Size of the mirror.
- **Set To Original Size**: Click this button to set the mirror size equal to its source size.
- **Transparency**: Specifies transparency level of the object. (0-Solid, 255-Most Transparent). Transparency is drawn into the produced video; not displayed in design mode, click the 'Preview Frame' button in the toolbar to preview the frame, or 'Preview Video' button to preview video. Drawing transparent objects takes more time to complete processing during 'Produce Video' process.
- **Effect**: Negative effect can be applied to mirror.
- **Border**: Draws border for the mirror object. Border is drawn into the produced video; not displayed in design mode, click 'Preview Frame' button in the toolbar to preview the frame.
- **Show Objects**: Check this option in order to display existing objects (such as texts, callouts, pictures) in the mirror. Objects located behind the mirror will be displayed in the mirror. If this option is not checked, objects will not be displayed in the mirror.
- **Zoom In**: If checked, zoom in effect is applied for the frame length specified in the Length.
- **Zoom Out**: If checked, zoom out effect is applied for the frame length specified in Length.
- **Fade In/Fade Out**: Objects fade in or out in the produced video or previews; not displayed in design mode.

Right-click on a mirror object to display the **Object Menu**.

Click **Frame Preview** and **Video Preview** buttons located in the toolbar to preview the mirror effect and other effects on the object such as transparency which are not displayed in design mode.
7.2.5. Transition Object:

Click the button on the toolbar to add a transition into the video.

Available transitions are:

- Fade In
- Fade Out
- Center In
- Center Out
- Zoom In
- Zoom Out
- Vertical Open
- Vertical Close
- Horizontal Open
- Horizontal Close
- Wave Effect
- Water Wave
- Bend Effect
- Rotate Effect
- Circle Open
- Circle Close

Screenshots of Video Transitions:

- Fade In - Fade Out
- Center In - Center Out
Add Pair: If checked, Movie Lab automatically adds the reverse pair of the transition such as Zoom in and out, vertical open and close etc.

Display duration of the transition is set to its default value starting from the current frame. Start and end frames and durations of a transition can be easily changed from the Video Grid Window by sizing and moving object's bar; or by entering values to Object Duration Setting:
Grid Window:

Object Duration Setting:

<table>
<thead>
<tr>
<th>OBJECT DURATION</th>
<th>START</th>
<th>END</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame: 40</td>
<td>Frame: 45</td>
<td>Frame: 84</td>
</tr>
<tr>
<td>Time: 4 seconds</td>
<td>Time: 00:00:04</td>
<td>Time: 00:00:07</td>
</tr>
</tbody>
</table>

Following properties of a transition can be specified by user:

- **Object No**: Shows the object number of the selected object.
- **Type**: Shows type of the selected object.
- **Color**: Specifies the color to be used in the transitions where required. For instance, while the image of the video frame is transformed for the transition effect, this color is used for the blank areas.
- **Style**: Type of transition.
- **X,Y**: Location of the transition icon. X-Y coordinates in pixel. This doesn’t have any effect on the production of the video.
- **Width, Height**: Size of the transition icon in the design mode. This doesn’t have any effect on the production of the video.
- **Disabled**: When checked, the transition will not be applied to the video.
- **Preview Window**: Effect can be previewed here if ‘Preview In Properties’ option is checked in the View menu.
- **Reverse**: Applicable only to Wave Effect, Water Wave, Bend, Rotate transitions. Reverses the transition.
- **Density**: Applicable only to Wave and Bend transitions. Specifies the density level of the transition.
- **Audio Fade**: Fades in or out the audio of the video during the transition.

Right-click on a transition object to display the Object Menu.
Click **Frame Preview** and **Video Preview** buttons located in the toolbar to preview transition effects which are not displayed in design mode.
7.2.6. Effect Object:

Click button on the toolbar to add an effect into the video.

Available effects are:
- Grayscale & Color Filter
- Colorize
- Brightness/Contrast/Color
- Blur
- Sharpen
- Noise
- Brush
- Emboss
- Rounded Mosaic
- Mosaic

Screenshots of Video Effects:

- Grayscale
- Color Filter (Green)
- Color Filter (Blue)
- Color Filter (Red)
**Display duration** of the effect is set to its default value starting from the current frame. Start and end frames and durations of a transition can be easily changed from the Video Grid Window by sizing and moving object’s bar; or by entering values to Object Duration Setting:

Grid Window:

<table>
<thead>
<tr>
<th>40</th>
<th>45</th>
<th>50</th>
<th>55</th>
<th>60</th>
<th>65</th>
</tr>
</thead>
<tbody>
<tr>
<td>▶</td>
<td>▶</td>
<td>▶</td>
<td>▶</td>
<td>▶</td>
<td>▶</td>
</tr>
</tbody>
</table>

Object Duration Setting:

<table>
<thead>
<tr>
<th>OBJECT DURATION</th>
<th>START</th>
<th>END</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame: 40</td>
<td>Frame: 45</td>
<td>Frame: 84</td>
</tr>
<tr>
<td>Time: 4 seconds</td>
<td>Time: 00:00:04</td>
<td>Time: 00:00:07</td>
</tr>
</tbody>
</table>

Following properties of an effect can be specified by user:
Object No: Shows the object number of the selected object.
Type: Shows type of the selected object.
Style: Type of effect.
X,Y: Location of the effect icon. X-Y coordinates in pixel. When ApplyTo property is set to Internal or External then these X and Y values defines the X, Y locations of the effect to be applied on the video.
Width, Height: Size of the effect icon in the design mode. When ApplyTo property is set to Internal or External then these values defines the width and height of the effect to be applied on the video.
Disabled: When checked, the effect will not be applied to the video.
Color Bar (Colorize): Color is selected in color bar for applying the 'Colorize' effect.
Preview Window: Effect can be previewed here if ‘Preview In Properties’ option is checked in the View menu.
Density Settings: Applicable to Saturation, Red/Green/Blue, Contrast, Brightness, Blur, Sharpen and Noise effects. Density level of the effect and colors can be specified.
Apply To: 1) All: Applies effect to full frame, 2) Internal (Highlight): Applies the effect only to the internal part of the specified area of the video, 3) External (Highlight): Applies the effect only to the external part of the specified area of the video. Internal and External options can be used for highlighting the user-specified areas in the video.

1) All: Applies effect to full frame,
2) Internal (Highlight): Applies the effect only to the internal part of the specified area of the video,
3) External (Highlight): Applies the effect only to the external part of the specified area of the video. Internal and External options can be used for highlighting the user-specified areas in the video.

Click Frame Preview and Video Preview buttons located in the toolbar to preview the effects which are not displayed in design mode.
Example To The Partial Application Of An Effect:

*ApplyTo* property of the Brightness/Contrast effect is set to *External (Highlight)*.

Screenshot of the effect object in design mode:

![Sample Project](image)

Application of the effect. Screenshot of the frame preview:

![Sample Project](image)

Right-click on an effect object to display the Object Menu.
7.2.7. Speed Object:

Click button on the toolbar to add a speed object into the video. Speed object slows down or speeds up the video where the object is added. By adding a speed object, speed of any part of the video can be changed. Change video speed by setting the Speed property in the Properties window.

Display duration of the speed object is set to 5 seconds by default starting from the current frame. Start and end frames and durations of a speed object can be easily changed from the Video Grid Window by sizing and moving object’s bar; or by entering values to Object Duration Setting:

Grid Window:

Object Duration Setting:

Following properties of a speed object can be specified by user:

Object No: Shows the object number of the selected object
Type: Shows type of the selected object.
Speed: Speed of the video (& audio) during the object in percentage.
X, Y: Location of the speed icon in X-Y coordinates in pixel.
Width, Height: Size of the speed icon in design mode.
Disabled: When checked, the object will not have any effect on the speed.
Play Audio: The user can specify whether the audio will be played during the speed object or not.

Right-click on speed object to display the Object Menu.
7.2.8. JumpTo Object:

Click button on the toolbar to add a JumpTo object into the video.

Movie Lab skips the part of the video where the users added a JumpTo object. The ‘To Frame’ value in the Properties window defines to which frame number BSR will jump to.

**Duration** of a JumpTo object is equal to the length of the part to be skipped and is set to 5 seconds by default. Start (Jump From) and end frames (Jump To) properties and durations of a jumpTo object can be easily changed from the Video Grid Window by sizing and moving object’s bar; or by entering values to Object Duration Setting:

Grid Window:

Object Duration Setting:

<table>
<thead>
<tr>
<th>OBJECT DURATION</th>
<th>START</th>
<th>END</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame: 40</td>
<td>Frame: 45</td>
<td>Frame: 84</td>
</tr>
<tr>
<td>Time: 4 seconds</td>
<td>Time: 00:00:04</td>
<td>Time: 00:00:07</td>
</tr>
</tbody>
</table>

Following properties of a JumpTo can be specified by user:

- **Object No**: Shows the object number of the selected object
- **Type**: Shows type of the selected object.
- **From Frame**: Skips video starting from this frame number. This frame will not be included into the produced video.
- **To Frame**: Skips video to this frame number. This frame will be included into the produced video.
- **X,Y**: Location of the JumpTo icon in X-Y coordinates in pixel. This doesn’t have any effect on the production of the video.
- **Width, Height**: Size of the JumpTo icon in design mode. This doesn’t have any effect on the production of the video.
- **Disabled**: When checked, the jump will not be done.

Right-click on JumpTo object to display the Object Menu.
7.3. WORKING ON A PROJECT:

7.3.1. Creating A New Project:

Click to New Project (Open AVI File) item in the File menu or click the New Project button on the toolbar to create a new project. Movie Lab will ask you to select a video (AVI) file to open.

7.3.2. Adding Objects:

Objects can be added either from the toolbox by clicking or dragging into the video frame or from the Edit menu:
Objects can also be added with copy-paste functions by either pressing Ctrl+C keys for copying and Ctrl+V keys for pasting, or clicking the copy and paste buttons in the toolbar or from the object menu by right-clicking on the object:

![sample_text](image)

### 7.3.3. Editing Object Properties:

Properties of a selected object are displayed in the Properties window which is located at the right of screen. You can enter new values or change the options for an object from the Properties window.

Example; properties of a text object:
You can move and resize the objects on the Video window.

Custom names (descriptions) can be entered for each object. These names are displayed next to the grid window:

**Display Order Of The Objects:**

By clicking the **Bring To Front** and **Send To Back** in the object menu, display orders of the objects can be changed.

**Grouping Objects:**

More than one object can be selected for grouping. Click **Group** and **Ungroup** in the object menu or from the toolbar to group or ungroup the selected objects. Multiple selected or grouped objects can be moved, resized, deleted, copied and pasted together.

The following properties will be available for the multiple selected objects:
Example : Grouping A Callout Object With Text :

1) Add a box from Callouts in the Toolbox :

2) Add a text object on to the callout box :

3) Add the tail from the Callouts in the Toolbox :

4) Group all into one by clicking the Group option in the right-click menu :

Undo - Redo Functions :

All changes can be undone by clicking the UNDO button in the toolbar or by pressing the Ctrl+Z buttons from the keyboard. REDO button or Ctrl+Y keys will redo.
7.3.4. Object Durations:

Durations, start frames and end frames of the objects can be set either from the Duration Settings in the control panel:

<table>
<thead>
<tr>
<th>OBJECT DURATION</th>
<th>START</th>
<th>END</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame</td>
<td>40</td>
<td>45</td>
</tr>
<tr>
<td>Time</td>
<td>4 seconds</td>
<td>00:00:04</td>
</tr>
</tbody>
</table>

Or from the object menu by right-clicking the object:

Or from the grid window:

All objects added into the video can be seen in the grid window. Objects are represented with different colors according to their types (text, picture, image, mirrors, transitions, effects, JumpTo and speed objects). Start and end frames and durations of each object can be easily changed from the Grid Window by sizing or moving that object’s bar. Scissors buttons on the toolbar can also be used to cut the length of the objects:
7.3.5. Deleting Objects:

To delete the selected object(s), simply press the Delete key on your keyboard, or delete button in the toolbar or from the object menu. Deletion of object(s) can be undone by clicking the Undo button in the toolbar or by pressing Ctrl-Z keys from the keyboard.

7.3.6. Frame And Video Preview:

Some of the effects added into the video such as the transparency of the objects, transitions, fade-in, fade outs etc. which will be added into the produced video are not displayed in the design mode but can be previewed by clicking the Frame Preview (or press F12 key) and Video Preview (or press F11 key) buttons located in the toolbar or from the View menu:

Since drawing these objects into the video keep longer times during the preview, the preview will be slower than the normal playback speed of the video. Once the final video is produced, it will be played with its normal speed, clear and all properties of the objects which are not displayed in the design mode will be displayed in the video.
7.3.7. Replace AVI:

The video which the user is working on and Movie Lab objects were added, can be changed later by clicking Replace AVI in the Edit menu. The AVI file which be replaced with the current one must have the same dimensions and video frame length.

7.3.8. Repair Project File:

If somehow a BSR project file is corrupted, Repair Project File in the Help menu may help fixing the file. Nevertheless, we recommend taking backups of the important project files, AVI files and external objects added in to the project such as the pictures and video files.
7.4. PRODUCE VIDEO:

BSR Movie Lab produces the video (AVI) with the objects existing in the project.

Options for video production:

Video Format:

Video can be produced in AVI, WMV, SWF or EXE formats.

Video Size:
For the dimension of the new video, either the original size, or a standard (pre-defined) size or a custom user-defined size can be selected.

**Stretch To Fit**: If the aspect ratio of the destination video dimension is not same with the original one, this option can be selected to stretch the video to the borders. In that case, the video will not be in the original aspect ratio.

**Backcolor**: If the aspect ratio of the destination video dimension is not same with the original one, the color specified here will be used as the background color.

**AVI Compression**: The original codec or a different one can be selected for creating the new video.

**AVI Speed**: The original speed of the selected AVI file or a custom speed can be selected.

**Reconstructing Video For A New User-Specified Playback Speed**: Movie Lab can also be used to reconstruct the video to a selected fps amount between 1 to 30. It reconstructs file by adding new frames or removing existing ones. For example when converting 30 fps to 15 fps, it removes one frame from every two. Or when converting 15 fps to 30 fps, it duplicates each frame.

According to the video format selected, WMV, SWF and EXE Settings can be done by clicking the related setting button.

Click 'Produce Video' button to start the creation of the video. BSR Movie Lab will draw objects into the video frames. Number of objects and number of transparent objects included in the project will affect
the process completion time. You can press ESC key or click 'Cancel' button to terminate the process. In this case, the processed part of the video will be saved.
TROUBLESHOOTING

Does this product record video from a video media player while playing on my PC?

BSR Screen Recorder can record anything you see on your screen. Please try the trial version before you purchase:

You can download and install the trial version of BSR from the following link:

http://www.bsrsoft.com/downloadbsr.asp

Texts are not sharp enough, they seem blurry:

You should try to change the compression you're using for recording from Options->Video tab->Video Compression settings. For instance, the default video codec does not provide a clear display of texts in full screen mode. You can try to record with Xvid or DivX codecs.

What is the maximum time that I can record a video with BSR Screen Recorder? Can it record up to 8 hours non-stop?

The only criteria for the limit of a recording is your harddisk capacity. While recording, when the file exceeds a specific size (1.9 GB by default) , BSR Screen Recorder saves the file and automatically switches to a new file.

Video Recording (or snapshot feature) does not provide sharp (or smooth) captures:

In the 'Other Settings' you will see the draw mode options for video and picture captures. 'Smooth' will record with 'blurring' on them, 'Sharp' will produce sharp pictures/video displays.

SWF file plays fine to a point and then the screen goes completely red

Red playback shows that Flash Media Player consumes too much memory to play the swf. This is related to the Flash Media Player's memory handling. Reducing the “Playback Rate” will help Flash Player to consume less memory. For reducing the Playback Rate, click Advanced button in the SWF converter and reduce Playback Rate value.

Why the recording video is blank (black screen)? I cannot record video from a media player, DVD etc.
Screen recorder applications cannot record overlaid video from the screen unless you do some settings. Some videos like DVD videos are overlaid on screen by the media players which prevents screen capturing.

**On Windows Vista & Windows 7:**

- Right click to your desktop (on the wallpaper)
- Click Personalize
- Click Display Settings
- Click Advanced Settings button
- Click Troubleshoot tab
- Click Change Settings button
- Turn off the hardware acceleration (if the option is disabled then you should try to turn off the video overlay from the media player’s settings as described below: )

You may also need to turn off the hardware acceleration/video overlay from the media player’s settings. Or you can try to play the video with another media player for recording from screen.

You can turn off the video overlay in Windows Media Player by doing the following:

1. On Windows Media Player, to open the popupmenu, click “Now Playing” on the top, or right-click to the blank area (black bar) below, just near to the play button section. Or right-click to the blank bar above (the menu area).
2. In the Tools menu, click Options, and then click the Performance tab.
3. Uncheck Turn On DirectX Video Acceleration for WMV files option. (Or, if the Advanced button exists, click the Advanced button. In the Video Acceleration area, clear the Use overlays check box.)
4. Restart Windows Media Player and try to record again.

If the video acceleration cannot be deactivated then you should use another media player which doesn’t use video acceleration to play the video you will record.

**On Windows XP:**
Check 'Disable Video Acceleration When Recording' option in Options->Video tab. This will provide BSR to disable and enable hardware acceleration of the system (except on Windows Vista or Windows 7, for Vista/7 see below) automatically and should prevent blank recording. But, if still you get blank video, then, you should also turn off the hardware acceleration/video overlay from the media player’s settings. Or you should try to play the video with another player for recording from the screen.

You can turn off the video overlay in Windows Media Player by doing the following:

1. On Windows Media Player, to open the popupmenu, click “Now Playing” on the top, or right-click to the blank area (black bar) below, just near to the play button section. Or right-click to the blank bar above (the menu area).

2. In the Tools menu, click Options, and then click the Performance tab.

3. Uncheck Turn On DirectX Video Acceleration for WMV files option. (Or, if the Advanced button exists, click the Advanced button. In the Video Acceleration area, clear the Use overlays check box.)

4. Restart Windows Media Player and try to record again.

If the video acceleration cannot be deactivated then you should use another media player which doesn’t use video acceleration to play the video you will record.

**Can the recorded video be saved in a wide screen format?**

BSR Screen Recorder can produce recorded video in any video dimension in its Movie Lab.

After you record the video, you should open it in the BSR Movie Lab, click Produce Video in the File menu and specify the dimensions of the video in pixels.

For wide screen the ratio of the video is important. The ratio should be 16:9 such as 800 x 450 pixels, 400 x 225 pixels.

**How can I delete a section of a video?**

You can either do this in Movie Studio->Extract. (You can open the Movie Studio by clicking the Studio button on the main interface.) Here, you can select the part of the video you want to delete.

Or, you can do it in Movie Lab by adding JumpTo object anywhere on the video. The video will skip the frames you added JumpTo objects.
How can I blank over a certain part of the screen video (for example to keep an account number confidential)?

Option 1: Open the video in the Movie Lab and then add any object over the account number, such as text box (you can delete the text in it) and check the fill property of it.

Option 2: Add a mosaic effect. Click add effect in the toolbox and click mosaic. Move the object over the part of the screen you want to add mosaic. By default, this object will be applied to the whole frame. In order to apply the mosaic effect on to the screen area you specify only, change the ‘ApplyTo’ option to ‘Internal’ in the properties window (at the most right of the screen).

Finally edit the start frame and end frame of the object.

You can preview the video by clicking the ‘Preview Video’

Click 'Produce Video' in the File menu to create the video.

I cannot record audio from Speakers (what I hear from the speakers) into my video:

First of all, you should check if the sound card on your computer supports recording audio of what you hear from the speakers.

A) To find out if your sound card supports recording from the speakers ("what you hear"):

1) If you have Windows Vista or Windows 7, the following parts of our troubleshooting web page will help:

http://www.bsrsoft.com/troubleshooting.asp#AudioInVista

_ and _

http://www.bsrsoft.com/troubleshooting.asp#AudioVista2

2) For other Windows OS including Windows XP:

From the main interface of BSR;

- Click Options

- Click the Audio Tab
- Check if the “Speakers” option is listed under “Record Audio From” list.

If the Speakers option (or one of “Stereo mix”, “mono mix”, “Wave-Out”, “What U Hear” or something similar) is not listed, the following link to our related part of troubleshooting web page will help:

http://www.bsrsoft.com/troubleshooting.asp#SpeakersGrayedOut

B) If you’ve found that your sound card has an input line for recording from the speakers, but it is still not recording, it means that you either didn’t activate the right input channel or the recording volume levels are too low. For help you should read related parts of our troubleshooting web page:

1) For Windows Vista/Windows 7:

http://www.bsrsoft.com/troubleshooting.asp#AudioInVista

2) For other Windows OS including Windows XP:

http://www.bsrsoft.com/troubleshooting.asp#SoundMuted

C) If you’ve found that your sound card doesn’t have such an input line for recording from the speakers:

http://www.bsrsoft.com/troubleshooting.asp#AudioVista2

It doesn’t record audio or the sound comes in very muted. It can hardly be heard.

You should check the recording (not playback) volumes by doing the following:

- Click the “Options” button on the main interface of BSR
- Click the “Audio” tab
- Click to the ‘Recording Volumes’ button and increase the volumes of each device.
- Close the volume setup window.
- Click “Record Audio From” list box and select the audio source you want to record from such as microphone, line-in, CD, speakers etc.
- Activate “Record Audio” option. And now you can record with BSR. Check if your computer receives audio signal from the audio source (such as the microphone). It will not record audio if the selected device can not transmit audio signals to your computer.
If still not recording audio and you're sure that the recording volume is turned on, then:

- Click the “Options” button on the main interface of BSR
- Click the “Audio” tab
- Check “Amplify Recording Volume” option
- Try to record again.

If still not recording audio and you're sure that the settings are normal, then (Only on Windows XP):

- Click the “Options” button on the main interface of BSR
- Click the “Options” tab
- Click “Other Settings” button
- Enable “Reverse mixer audio lines” option in the Audio Settings group.
- Try to record again.

You can also do these audio source selection settings manually from Windows' Settings: (Only on Windows XP. For Windows Vista/Windows 7 click here)

- Open Volume Control of Windows (This can be done by double click on Speakers icon in the system tray (where the computer time is displayed))
- Click Options in the menu and Properties, select Recording option. Select all volume controls in the list and click Ok.
- Now you can select the audio source (such as microphone) and set its volume
- Activate audio recording by left-clicking on the Microphone icon on BSR main panel. And now you can record with BSR.

**When recording webcam sessions, is it possible to capture audio both from microphone and speakers at the same time?**

BSR Screen Recorder (BSR) uses the sound card input lines to record audio. For recording the audio from the speakers (‘What you hear’), BSR sets the input channel of the sound card to ‘Speakers’. However, at
the same time, the webcam chat software needs to change the input line of the sound card to 'Microphone' in order to be able to transmit your voice to the other party. Therefore, since the webcam chat software changes the audio source input line of the sound card to 'Microphone', BSR will only be able to record sound from your microphone during the video conversation.

For recording the both channels (microphone and speakers) at the same time you may need to use a separate sound recorder which is mainly designed for recording VoIP.

The 'Speakers' option in the audio source selection is grayed out or not listed.

If the 'From Speakers' option is grayed out or not listed, it means that your sound card doesn't support recording from speakers. Almost all sound cards have wave-in lines for microphones, CD Audio, midi etc but some of them do not include a wavein line for Stereo Mix or Mono Mix which provide audio recording from speakers.

Please check this manually from Windows Volume Control window: (For Winows Vista/Windows 7 click here)

- Open Volume Control of Windows (This can be done by double clicking on Speakers icon in the system tray (where the computer time is displayed)) or running sndvol32.exe will bring up the same window.
- Click Options in the menu and Properties, select Recording option. Select all the volume controls in the list and click Ok.
- These are all wave-in lines provided by your sound card. If "Stereo Mix", "Mono Mix", "Speakers", "What You Hear" or something similar exists, you can select it as the audio source and set its volume. Now, BSR will record from Speakers even if the option is grayed out.

Screen Recorder records audio from microphone in spite of setting it to record from Speakers or records from speakers instead of microphone :

Enabling 'Reverse Mixer Channels' option which is located in the 'Other Settings' of BSR Screen Recorder will fix the problem.

I cannot record audio. It returns one of the following errors : "Couldn't find a Wave_In line in mixer!", "Couldn't find any source line for audio input!" or any other message related to 'Mixer'.

The error shows that your sound card does not provide a wave in line for audio recording. The reason for that may be :

1) Your sound card does not record audio at all. In order to understand you can try to record audio with Microsoft Sound Recorder (sndrec32.exe -> which is located in the Windows/System32 directory). You should make necessary settings such as unmuting and opening record volume of microphone. If you can record at least from microphone and listen to it, then, close Microsoft Sound Recorder and try to record with BSR Screen Recorder. Normally if Sound Recorder records audio from microphone then BSR should record audio too. (Even it returns the error message.)
2) Second reason may be that your sound card is not Microsoft supported and its driver may need to be updated.

**Audio is not synchronized with the video:**

Capture performance is very important for audio synchronization. To view and increase the capture performance:

After completing a recording, an information window is opened which includes grading for the last capture performance. You can click on the small button to view the capture performance graph. (Another way to open the capture performance graph is to click the Menu button on the main panel (the button just below the red Flash button) and click to ‘Last Performance Report’ button.) That window will show you the performance of the computer during last recording. Low performance will prevent audio synchronization since the computer omits many frames during recording. There are two options just below the graph:

- Set Higher Priority For BSR Screen Recorder (this is already activated by default)
- Disable Video Acceleration During Recording

Activating these two options will increase the capture performance. You should also either close other applications running in your computer which keep CPU busy or wait their tasks finish (such as backups, virus scans and other CPU intensive background tasks).

Finally, you can also use the synchronization feature in the Movie Studio for synchronizing the videos you recorded. While watching the video in the synchronizer, you can use -2x, -1x, +1x, +2x buttons to increase/decrease the video speed until you decide that the video & audio are synchronized.

**At first, the audio quality was very good, now it is broken up:**

You should change the audio quality from:

Right-click to microphone icon on the main panel and click Audio Quality Settings (or from Options->Audio tab-Audio Quality Settings.

For instance, you can try recording with 8 bit sound. The default settings are 22,050 kHz, 8 bits, Mono.

**I have a Realtek sound card and I cannot use the audio settings in BSR Screen Recorder.**

If a sound card doesn't use the Windows drivers, BSR cannot change its settings. You should change its settings manually. Open the Realtek sound panel and unmute the Stereo Mix channel for recording.
audio of what you hear from the speakers (or the microphone channel for recording audio from the microphone) in the Mixer tab.

**Audio Settings on Windows Vista/Windows 7 (How can I record audio from speakers on Windows Vista/Windows 7? How can I set audio source and recording sound levels on Windows Vista/Windows 7?):**

- Click Options button on the main interface of BSR

- Click Audio tab

- Click Settings For Recording Audio From Speakers button

- It will direct you to find out if the sound card on your computer is capable of recording audio from speakers and then how to activate recording audio from speakers.

Steps are also explained below:

a. **Enabling Sound Recording From Speakers on Windows Vista/Windows 7:**

In order to be able to record from speakers you should first activate it from Windows' settings which is deactivated by default on Windows Vista and Windows 7:

1. Right-click on the microphone icon on the main panel and click to 'Audio Source Settings in Windows VISTA/Windows 7'. Sound control panel of Windows will open.

2. In the Recording tab, you will see your devices enabled for audio recording. Right-click anywhere on any device or in the white blank area. Click on Show Disabled Devices in the popup menu.

3. If your sound card supports, 'Stereo Mix', 'Mono Mix', 'Wave-Out', 'What U Hear', or something similar will appear. Right-click on that device and click Enable.

4. Now select the device you enabled or another one which you want to use for your audio recording and click Set Default.

b. **Setting Audio Source and Recording Sound Levels on Windows Vista/Windows 7:**

1. Right-click on the microphone icon on the main panel and click to 'Audio Source Settings in Windows VISTA'. Sound control panel of Windows will open.

2. In the Recording tab, select the device which you want to use for your audio recording and click Set Default.
3. Double click on the device or click on 'Properties'. Click on 'Levels' tabs for setting the recording volume level of the device. After setting the volume click OK. If the green input level meter rises while the sound produced in the device you should be able to record audio from that device.

I've followed the instructions but still cannot record audio of what is heard from the speakers.

BSR can record audio only from the sources that the sound card supports. If your sound card doesn't have an input line for recording audio from the speakers, BSR cannot record audio from the Speakers. Usually the input audio line which provides recording from the Speakers is named as “Stereo mix” or “mono mix” or “Wave-Out” or “What U Hear” or something similar. If one of these lines doesn't exist in the list as explained above, it means that your sound card doesn't have an input line for recording sound from the speakers.

**Solution 1:**

You can try connecting a cable (3.5mm audio cable with a male plug at each end) from the “line-out” (or audio out or headphone) port of the computer to the "line-in", and choose the “line-in” as the recording source in BSR. Or if a "line-in" port doesn't exit, you can also connect the cable from the "line-out" (or audio out or headphone) port to the "microphone" port and choose "microphone" as the recording source.

When you connect the cable to the headphone port, you may not be able to hear the computer sound. To solve this, you can connect a **3.5mm splitter** to the headphones port to be able to connect both the cable and a headphone.
Solution 2:

You should either install another sound card which supports that feature on your computer or use BSR on another computer which has a capable sound card.

Low Performance - Poor Playback - Jumpy Videos - Capture speed rate of the recording (capture performance) is very low:

If you receive the low performance message or the video you record comes up with poor playback (jumpy videos) then your computer's performance was not enough to do all those tasks at the same time. For example, if you're trying to record a video from internet, your computer tries to download and play it and at the same time BSR records it. The computer's performance seems not enough to do all these three tasks perfectly at the same. At least, you can try to wait until the video is downloaded and then record.

Low capture speed is mostly related to the computer's performance during the capture. For instance, when you set the recorder to record 30 fps, it will try to capture 30 frames per second and if computer's performance is not sufficient enough, resulting rate will be lower. In order to increase the capture speed, you should reduce the load on CPU:

- You should either close other applications running in your computer which keep CPU busy or wait their tasks finish (such as backups, virus scans and other CPU intensive background tasks).

- You can try to select a smaller region on screen for recording or use size functions in Video Dimensions settings in Configuration

- Also computer's performance (CPU speed, RAM amount and harddisk space) is an important factor on the capture speed rate.

- Check 'Disable Video Acceleration When Recording' option.

If the result is the same after these precautions, then, Set 'The Priority for Screen Recorder' option to High from:

- Click Configure

- Click Options tab
Set Priority of BSR to High.

This will cause Windows to give the highest priority to BSR among other applications and its performance will clearly increase.

If you want to get the maximum capture speed, you can also use No Compression (Full frames) option in Video Compression settings and record no audio if audio is not needed. Compression of each frame and audio recording keeps CPU busier. You can compress the video in the Movie Studio (Resample AVI) or in Movie Lab after you finish the recording and also add audio in the Movie Studio.

How can I reduce sizes of video files I record?

Converting recorded AVI files to SWF (flash file) or WMV format will reduce the file size significantly. You can convert AVI files to SWF and WMV with the converter of BSR Screen Recorder.

Reducing the AVI file size: The most important factor is the codec (compression) you use. Only the change to a better codec will provide a significant decrease in file size. For instance; DivX or XviD codecs will provide smaller file size and high quality. The second important factor is video dimension. In full screen recordings, you can use Video Dimension function in Options->Video Tab (in the old version: Configuration->Page I). For instance, set the ratio to 70%. This will shrink video to its 70% in size and will provide a smaller file size. Another factor is the audio quality. Increasing audio quality will also increase the file size.

You can use ‘Adviser’ of BSR from Options->Options tab->Run Adviser (in the old version Configuration->Page III->Run Adviser) to reduce file sizes.

You can also reduce the file size after your recording by opening the recorded file in Movie Lab:

- Click ‘Make Movie’ and set your new codec (such as DivX, XviD), new video dimension and reconstruct the video to a lower fps rate.

It will produce a new video file according to your settings.

What are the settings for better quality?

For better quality you can configure BSR as follows:

- Select DivX or XviD codec for recording which will provide better quality and smaller file size (if DivX or Xvid is not installed on your computer, you can download it from its web site. Xvid is free and DivX has a
trial version). Or you can use the Full Frames (uncompressed) option in the codecs. This will provide a better quality too but the file size will be high.

Codec can be selected from Options->Video Tab->Video Compression->Change

- Check ‘Disable Video Acceleration When Recording’ option in Options->Video tab (except on Windows Vista/Windows 7). This will prevent blank recording.

- Try selecting a smaller screen area for recording or reduce video dimension from Options->Video tab->Video Dimensions. This will increase the capture performance.

- You can also try setting priority of BSR Screen Recorder to high from Options->Options tab->Priority For BSR Screen Recorder->High.

**Audio Settings :**

Right-click on the microphone icon on the BSR main interface. All settings below will be done in that menu :

- Check recording volumes from Recording Volume Setup. Volume level can be configured from Options->Audio tab and also during recording.

- Click "Audio Quality Settings". Audio quality is set to 22,050 kHz, 16 bit, mono by default. If necessary, you can change increase this to a higher value to increase the audio quality (the higher quality setting, the higher file size).

**How can I increase the SWF quality?**

Click the Advanced button in the SWF convertor and set Quality setting to 32 bit colors.

**How can I increase quality for a WMV video (Windows Media Video)?**

Increasing the bitrate value in the WMV convertor will increase the quality.

**I have an old version of BSR Screen Recorder, how can I upgrade it to version 4? or how can I try the new version?**
Install the shareware version 5 into a different directory on your computer from the following links:


http://www.bsrsoft.com/download.asp?id=21

BSR Screen Recorder Full Version for Windows XP, Me, NT, 2000:

http://www.bsrsoft.com/download.asp?id=1

After you try the new version, if you decide to purchase the upgrade, click on 'Purchase' button in Options->About tab. You will see the 'Upgrade' option there.

For upgrading to version 5, full version 4 should be installed in your computer (or you can send an email to support@bsrsoft.com for directly updating to the version 5). Upgrading version 4 to version 5 is $19.95.

I purchased BSR Screen Recorder, but still there are watermarks on the videos

If still there are logos on the new videos you’re recording, it means that you didn't enter your license key into BSR Screen Recorder yet. However, the watermarks (BSR logos) on the videos already recorded with the trial version of BSR cannot be removed since they are already produced with watermarks on them.

How can I enter my license key into BSR Screen Recorder?

To enter the license key:

1) You can either click ‘Enter License Key' button in the directory selection window during the installation,

-or-

2) Enter the license key from Options->About tab->Purchase Now after the installation.

Is there any limitation to the trial version of the software? How long does the trial period last?

There is no time limit, you can use it as long as you want. Only limitation of the trial version is that it records watermarks on the video.
Is it possible to remove the watermarks from the previous videos I recorded with the trial version?

No, the watermarks on the videos already recorded with the trial version of BSR cannot be removed since they are already produced with watermarks on them. The purchased version of BSR stops recording watermarks on the new videos.

If I purchase the $39.95 version now, what would I do if I then decide I need the $89.95 version?

You can add BSR Movie Lab later by paying the difference ($49.95).

Purchase link for adding the Movie Lab to your existing BSR Screen Recorder license:


I want to purchase BSR Screen Recorder on Windows XP, will it be possible to change to Windows Vista or Windows 7?

Yes, you will be able to download and install any of them.

Will I be able to download the XP and Vista (or Windows 7) versions of BSR with one purchase?

Yes.

If I change my computer with a new one, or format my harddrive, will I be able to use the same license key?

Yes you can use the same license key when you change your computer with a new one.

Error message on Windows Vista:

Runing BSR Screen Recorder with Administrator rights should fix the problem:

- Right-click on the ‘BSR Screen Recorder 4’ (that you click to launch BSR) in the Start Menu

- Click to ‘Properties’

- Click ‘Compatibility' tab

- At the bottom, enable ‘Run this program as an administrator’ option.
- Click OK.

- Launch BSR by clicking on the ‘BSR Screen Recorder 4’ in the Start Menu

Vista will ask you to use the administrator account. Click ‘Allow’. Now it should work properly.

**Doesn't save video as WMV / doesn't convert to WMV**

You should try to install Windows Media Encoder on your computer from:

http://www.microsoft.com/windows/windowsmedia/forpros/encoder/default.mspx

**How can I select a video file to play back?**

Right-click to Play button (it is the button with the black triangle icon on the main panel) to select the media file you want to play.

**How can I close/disable tooltip balloons?**

You can enable/disable tooltip balloons from Options->Options tab->Disable Help Balloons.

**I have Windows Vista/Windows 7 installed on my computer and BSR doesn't run on it:**

BSR Screen Recorder has a separate installation for Windows Vista/Windows 7 which you can download from the following link:

http://www.bsrsoft.com/downloadbsr.asp
8. CREDITS

Perspective image transformation features of this product were created using Anti-Grain Geometry - Version 2.4:

***************************************************************************

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2004 Maxim Shemanarev (McSeem)

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears in all copies. This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2005 Maxim Shemanarev (McSeem)

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

***************************************************************************

For converting image files to or from JPG and PNG formats, CxImage library is used:

***************************************************************************

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

CxImage version 6.0.0 02/Feb/2008

CxImage : Copyright (C) 2001 - 2008, Davide Pizzolato
Original CImage and CImageIterator implementation are:
Copyright (C) 1995, Alejandro Aguilar Sierra (asierra(at)servidor(dot)unam(dot)mx)

Covered code is provided under this license on an "as is" basis, without warranty of any kind, either expressed or implied, including, without limitation, warranties that the covered code is free of defects, merchantable, fit for a particular purpose or non-infringing. The entire risk as to the quality and performance of the covered code is with you. Should any covered code prove defective in any respect, you (not the initial developer or any other contributor) assume the cost of any necessary servicing, repair or correction. This disclaimer of warranty constitutes an essential part of this license. No use of any covered code is authorized hereunder except under this disclaimer.

Permission is hereby granted to use, copy, modify, and distribute this source code, or portions hereof, for any purpose, including commercial applications, freely and without fee, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Other information: about CxImage, and the latest version, can be found at the CxImage home page: http://www.xdp.it

**************************************************************************
9. LICENSE AGREEMENT & DISCLAIMER OF WARRANTY

YOU SHOULD CAREFULLY READ THROUGH THE FOLLOWING TERMS AND CONDITIONS BEFORE USING THE SOFTWARE/ SOFTWARES (BSR SCREEN RECORDER AND/OR BSR MOVIE LAB). YOUR USE OF ONE OR BOTH OF THESE SOFTWARES INDICATES YOUR ACCEPTANCE OF THIS LICENSE AGREEMENT AND DISCLAIMER OF WARRANTY.

HEREAFTER, "THE SOFTWARE" REFERS TO BSR SCREEN RECORDER, BULENT'S SCREEN RECORDER AND/OR BSR MOVIE LAB, "THE AUTHOR" REFERS TO BULENT BALTACIOGLU.

THE OTHER NAME OF BSR SCREEN RECORDER IS BULENT'S SCREEN RECORDER. "BSR SCREEN RECORDER" REFERS TO "BULENT'S SCREEN RECORDER". "BULENT'S SCREEN RECORDER" REFERS TO "BSR SCREEN RECORDER."

YOU ARE EXPECTED TO USE THE SOFTWARE ON YOUR SYSTEM AND TO THOROUGHLY EVALUATE ITS USEFULNESS AND FUNCTIONALITY BEFORE MAKING A PURCHASE.

THIS LICENSE AGREEMENT PERMITS YOU TO USE THIS SOFTWARE ON ONLY ONE COMPUTER BY ONE USER AT A TIME. IF YOU DESIRE ADDITIONAL USERS OR TO INSTALL THE SOFTWARE INTO ADDITIONAL COMPUTERS, YOU MUST PURCHASE AN ADDITIONAL COPY OF THE SOFTWARE FOR EACH USER AND/OR EACH COMPUTER. THIS LICENSE IS NOT TRANSFERABLE TO ANY OTHER SYSTEM, ORGANIZATION OR INDIVIDUAL. YOU MAY MAKE ONLY ONE BACKUP COPY OF THE SOFTWARE. YOU MAY NOT COPY THE MATERIALS ACCOMPANYING THE SOFTWARE. YOU MAY NOT LOAN, RENT OR LEASE THE SOFTWARE. YOU MAY NOT REVERSE ENGINEER, DE-COMPILE, ALTER, MODIFY, DECOMPOSE OR DISASSEMBLE THE SOFTWARE AND/OR BINARY FORMAT FILES INCLUDED IN THE SOFTWARE.

THESE SOFTWARES AND THE ACCOMPANYING FILES ARE PROVIDED TO YOU ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND. BY USING ONE OR BOTH OF THE SOFTWARES, YOU AGREE TO BEAR ALL RISKS AND LIABILITIES ARISING FROM THE USE OF THEM. THE AUTHOR BULENT BALTACIOGLU (AND ANYONE ELSE WHO HAS BEEN INVOLVED IN THE SALE OR DELIVERY OF THE SOFTWARE) SHALL NOT BE LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OR LOSS. THE AUTHOR HAS NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.

BSR SCREEN RECORDER AND BSR MOVIE LAB ARE PHYSICALLY UNSEPARABLE AND INSTALLED TO USER'S COMPUTER TOGETHERLY. BY INSTALLING BSR SCREEN RECORDER INTO YOUR COMPUTER, YOU'RE ALSO ACCEPTING TO INSTALL BSR MOVIE LAB TOGETHER WITH IT. HOWEVER, BSR SCREEN RECORDER AND BSR MOVIE LAB LICENCES ARE SOLD SEPARATELY. LICENSE FOR BSR SCREEN RECORDER CAN BE PURCHASED ALONE WITHOUT PURCHASING THE LICENSE FOR BSR MOVIE LAB. HOWEVER, EACH BSR MOVIE LAB LICENSE IS BOUNDED TO A BSR SCREEN RECORDER LICENSE; IT IS NOT POSSIBLE TO PURCHASE BSR MOVIE LAB WITHOUT PURCHASING BSR SCREEN RECORDER. IN ORDER TO PURCHASE A LICENSE FOR BSR MOVIE LAB, FIRST, LICENSE FOR BSR SCREEN RECORDER MUST BE PURCHASED. USERS WHO PREFER TO
PURCHASE A LICENSE ONLY FOR BSR SCREEN RECORDER, ACCEPT THAT BSR MOVIE LAB WILL BE INSTALLED IN THEIR COMPUTER AS SHAREWARE. LIMITATION APPLIES FOR SHAREWARE VERSIONS OF THESE SOFTWARES BY RECORDING LOGOS (WATERMARKS) ON CREATED VIDEOS.

THIS LICENSE IS EFFECTIVE UNTIL TERMINATED. THIS LICENSE WILL TERMINATE AUTOMATICALLY WITHOUT ANY NOTICE FROM THE AUTHOR, IF LICENSEE FAILS TO COMPLY WITH ANY TERM OR CONDITION OF THIS LICENSE. THE LICENSEE AGREES UPON SUCH TERMINATION TO RETURN OR DESTROY THE WRITTEN MATERIALS AND ALL COPIES OF THE SOFTWARE.

IN THE EVENT OF INVALIDITY OF ANY PROVISION OF THIS LICENSE, THE REMAINDER OF THIS AGREEMENT SHALL CONTINUE IN FULL FORCE AND EFFECT.